1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Calling a BTM-file from explorer stops at promt after updating to 14

Discussion in 'Support' started by Theschalker, Jul 11, 2012.

  1. Theschalker

    Theschalker

    Messages:
    11
    I hope someone can help.
    .btm files are assigned with tcc, but after updating to version 14, when I double-click on a btm-file in explorer, tcc opens, and the batch files is not run, instead it stops at the promt, in the right directoy.

    So - am I missing something ? It has worked without any problems in version 13, but after updating I got this strange effect.
  2. Steve Fabian

    Steve Fabian

    Messages:
    3,531
    Show us the result of
    echo assoc .btm: %@assoc[.btm]
    echo ftype: %@ftype[%@assoc[.btm]]

    and verify that the command displayed by the second echo is the correct version of TCC.EXE
  3. Theschalker

    Theschalker

    Messages:
    11
    Steve, thanks for your reply.

    The results of the two commands are:
    [D:\]echo assoc .btm: %@assoc[.btm]
    assoc .btm: btm_auto_file

    [D:\]echo ftype: %@ftype[%@assoc[.btm]]
    ftype: "C:\Program Files\JPSoft\TCMD14x64\tcc.exe" ""

    I checked with regedit the entry for btm_auto_file.
    btm_auto_file
    shell
    open
    command
    The entry under command is: "C:\Program Files\JPSoft\TCMD14x64\tcc.exe" "%1"
  4. vefatica

    vefatica

    Messages:
    5,107
    Neither look like mine (Win7/32). Did you let Windows create the "btm_auto_file" type? My association was created with the distributed TCCBATCH.BTM. That BTM file uses code like this:
    Code:
    echos Do you want to make TCC the default handler for .BTM files [Y/N] ?
    inkey /k"yn[enter]" %%var
    iff "%var" eq "y" then
        assoc .btm=TCC.Batch
        ftype TCC.Batch="%_cmdspec" /c "%%1" %%*
    endiff
    And my registry entries seem appropriate:
    Code:
    v:\> assoc .btm
    .btm=TCC.Batch
     
    v:\> ftype TCC.batch
    TCC.batch="G:\TC14\TCC.EXE" /c "%1" %*
  5. Theschalker

    Theschalker

    Messages:
    11
    Vince,

    I deleted all btm_auto_file entries, used tccbatch.btm, and at least the results of assoc .btm and the ftype command look like yours, except for the part to JPSoft.
    BUT - all it does, when I double-click on a .btm file ist to launch tcc, and then stops at the promt without callicg it.
    manually the calling file can be started, but that is about it !

    I used the tcmd.ini file I had in version 13. If I use that, the prompt is in the directory, from where I call the .btm.
    It does the starting directoy, but it would neever call the .btm file.


    Entries in the tcmd.ini are:



    CompleteHidden=No
    ProxyPort=80
    FirewallType=None
    FirewallPort=1080
    PassiveFTP=Yes
    FTPTimeout=120
    HTTPTimeout=120
    TFTPTimeout=120
    MailPort=25
    RLocalPort=0
    SHLocalPort=0
    SSHPort=22
    SSLStartMode=0
    SSLPort=0
    ANSI=Yes
    CDDWinLeft=20
    CDDWinTop=20
    CDDWinWidth=300
    CDDWinHeight=140
    ColorDir=dirs: bright magenta; com exe bat btm cmd:bright cyan;c cpp h hpp:bright blue;zip arj lha rar: bright red;dat fis f3dat: green; sav f3sav flac3d: bright red
    Editor=C:\Program Files (x86)\Multi-Edit 2008\mew32.exe
    ErrorColors=Bright Red on Black
    InputColors=Bright White on Black
    PopupWinHeight=347
    PopupWinTop=136
    PopupWinLeft=190
    PopupWinWidth=656
    StdColors=Bright White on Black
    WindowHeight=0
    WindowState=Custom
    WindowWidth=0
    WindowX=0
    WindowY=0
    Transparency=255
    InactiveTransparency=255
    AppendToDir=Yes
    CompleteHiddenFiles=Yes
    CompleteHiddenDirs=Yes
    CompletePaths=No
    CompletePercents=No
    CursorIns=100
    CursorOver=15
    DirHistory=10240
    DirHistoryOnEntry=Yes
    EditMode=Overstrike
    FuzzyCD=0
    HistMin=0
    History=24576
    HistCase=No
    HistCopy=No
    HistDups=Off
    HistMove=No
    HistWrap=Yes
    ServerCompletion=Local
    AmPm=No
    BeepFreq=440
    BeepLength=2
    CommandSep=&
    DecimalChar=Auto
    DescriptionMax=512
    NTFSDescriptions=No
    Descriptions=Yes
    EscapeChar=^
    EvalMax=10
    EvalMin=0
    ExpandPseudovariables=Yes
    ParameterChar=$
    RegularExpressions=Perl
    SwitchChar=/
    TabStops=8
    ThousandsChar=Auto
    AutoCancel=Yes
    AutoCDD=Yes
    AutoRun=Yes
    BatchAliases=Yes
    BatchEcho=Yes
    CMDExtensions=No
    CopyPrompt=No
    DelayedExpansion=No
    DelGlobalQuery=Yes
    DirJunctions=Yes
    DuplicateBugs=Yes
    ExecWait=No
    HistLogOn=No
    LocalAliases=No
    LocalDirHistory=No
    LocalFunctions=No
    LocalHistory=No
    LogAll=No
    LogOn=No
    LogErrors=No
    MouseWheel=Yes
    NoClobber=No
    PathExt=No
    Perl=No
    Python=No
    RecycleBin=Yes
    Rexx=Yes
    Ruby=No
    SettingChange=No
    SHChangeNotify=No
    Tcl=No
    UnicodeOutput=No
    UnixPaths=No
    UpdateTitle=Yes
    WebHelp=No
    Win32SFNSearch=No
    Wow64FsRedirection=Yes
    ZoneId=0
    [TakeCommand]
    CommandInput=Yes
    AlwaysOnTop=No
    AppendToDir=Yes
    CompleteHiddenFiles=Yes
    CompleteHiddenDirs=Yes
    CompletePaths=No
    CompletePercents=No
    IBeamCursor=No
    InactiveTransparency=255
    ServerCompletion=Local
    SingleInstance=No
    Transparency=255
    Tray=No
    WindowState=Standard
    AutoAttachConsoles=No
    ConsoleBufferRows=5000
    IBeamCaret=No
    LeftAltKey=Yes
    LeftCtrlKey=No
    RightAltKey=No
    RightCtrlKey=No
    SmoothScroll=No
    SplitterWindows=No
    StartTabWait=0
    TabStdColors=Bright Green on Black
    TabIcons=Yes
    Tabs=Top
    TabSize=20
    TabRotation=No
    TabX=Selected
    AutoUpdateFolders=No
    CloseIfNoTabs=Yes
    ClosePrompt=Yes
    DescriptionMax=512
    Descriptions=Yes
    LinuxSelection=No
    LockExplorerBar=No
    LockMenuBar=No
    LockTabBar=No
    MinimizeOnClose=No
    MouseWheel=Yes
    NTFSDescriptions=No
    PathExt=No
    RegularExpressions=Perl
    SettingChange=No
    SHChangeNotify=No
    ShowHiddenFiles=Yes
    ShowSysFiles=No
    ShowSuperHidden=No
    SingleClick=Yes
    ShowExtensions=Yes
    StartDirectory=d:\
    UpdateTitle=No
    WebHelp=No
    Wow64FsRedirection=Yes
    ZoneId=0
    [PopupFont]
    Font=Lucida Console
    Size=-13
    Weight=400
    Italic=0
    Script=0
    [ListView]
    Style=3
    [TCFilters]
    1=*.pdf
  6. Charles Dye

    Charles Dye Super Moderator Staff Member

    Messages:
    2,588
    And what does this command report now?
    Code:
    ftype %@assoc[.btm]
    
  7. Theschalker

    Theschalker

    Messages:
    11
    ftype %assoc[.btm] reports
    TCC.Batch="C:\Program Files\JPSoft\TCMD14x64\TCC.EXE" /c "%1" %*


    When I double-click on a .btm file, tcm starts, with the tcc prompt, ending up in the right directory (from where I started the batch).
    but the batch itself is not started.

    Let windows assign the btm_auto_file has worked with all version prior to 14. Is there possibly something wrong with some entries in the settings or an ini file, which were transferred from the previous version during the installation ?
  8. Theschalker

    Theschalker

    Messages:
    11
    Ok - the problem has been resolved.
    After following all of your recommendations, I let Windows 7 again assign tcc to the .btm files, and VOILA - it works.

    The results of the two commands you asked me to type are:

    echo assoc .btm: %@assoc[.btm]
    assoc .btm: TCC.Batch

    echo ftype: %@ftype[%@assoc[.btm]]
    ftype: "C:\Program Files\JPSoft\TCMD14x64\TCC.EXE" /c ""


    Anyway, thanks for your help !!!!

Share This Page