A strange one

May 20, 2008
11,400
99
Syracuse, NY, USA
I noticed a strange behavior while messing with big dirs on a network (another thread). First v19, which I cannot make misbehave.
Code:
v:\> \\zz\v$\20000files\

\\zz\v$\20000files> dir

^C
\\zz\v$\20000files> 44.*
TCC: Unknown command "44.*"

\\zz\v$\20000files> dir 44.*

 Directory of  \\zz\v$\20000files\44.*

[188 files, listed as expected]

                   0 bytes in 188 files and 0 dirs
       8,603,136,000 bytes free

Now with v20. The first time, I accidentally typed "44*" while the original DIR was in progress.
Code:
v:\> \\zz\v$\20000files\

\\zz\v$\20000files> dir

^C
\\zz\v$\20000files> 44.*
TCC: Unknown command "44.*"

\\zz\v$\20000files> dir 44.*

 Directory of  \\zz\v$\20000files\44.*

[Only the first 112 files are listed
followed by 76 blank lines
and the partial summary below]

       8,603,136,000 bytes free

At this point, my TITLEPROMPT fails to appear in the title bar. And many commands, but not all, produce only blank lines as output. For example. VER.
Code:
\\zz\v$\20000files> ver



\\zz\v$\20000files>

This happens in any newly instance of v20.

On another computer, there's misbehavior, but not quite the same. After those other commands, The "DIR 44*" stops short.
Code:
\\lucky\v$\20000files> dir 44*

 Directory of  \\lucky\v$\20000files\44*

SNIP
2016-11-09  11:22               0  44.4171707993
2016-11-09  11:21               0  44.4242083754
2016-11-09  11:22               0  44.4250388814
                   0 bytes in 186 files and 0 dirs
      19,666,403,328 bytes free

It stops there, though there are more files:

Code:
\\lucky\v$\20000files> dir 44.5*

 Directory of  \\lucky\v$\20000files\44.5*

2016-11-09  11:22               0  44.503284011
2016-11-09  11:21               0  44.517285053
2016-11-09  11:21               0  44.529272279
2016-11-09  11:21               0  44.566077397
                   0 bytes in 4 files and 0 dirs
      19,666,403,328 bytes free
 
Similar threads
Thread starter Title Forum Replies Date
R strange bug? Support 7
Jesse Heines Strange Line Wrapping Behavior Support 14
F strange results Support 9
M Strange error messages from TCC in FTP copy Support 7
M Another possibly strange remote registry issue Support 5
forbin Strange handling of [nonbright] magenta background (v22) Support 2
N Fixed Strange dir behavior Support 6
vefatica REGDIR, strange error message Support 7
T WAD Strange Unexpected "features" in the Debugger Support 2
P Strange mouse behavior with list Support 2
vefatica Strange tcc.exception.log Support 7
D Strange DO behavior with /O Support 5
Glenn Bowes Strange text at startup Support 5
Steve Pitts WAD Strange output from DEL of a non-existent directory Support 7
vefatica Big numbers, strange errors Support 1
aedthuio Strange... lpksetup Support 4
CWBillow dir /4 strange Support 2
D Strange issue with FOR loop Support 15
MikeBaas Strange prob with %@replace.. Support 4
vefatica OT: strange files in %TEMP Support 10
Dan Glynhampton Documentation v15 help: Strange links in @INT topic Support 0
R WAD Strange output from "memory" command Support 1
M Yet another strange something re something called "@TCONVERT" Support 8
Roedy How to? Strange colours Support 9
M WAD Strange "Start" misbehavior... Support 10
vefatica Very strange console font corruption Support 3
Steve Pitts Strange problem with FREE Support 10
A strange error in alias Support 9
newgeekorder Debugger IDE - strange tab and parameter behaviour Support 1
Exolon Strange Prompt. Support 6
vefatica Strange folders Support 1
T Strange CPU value Support 3
J Strange error: unset /s Support 14
M Strange behavior... Support 2
CWBillow Strange happenings Support 2
B Strange handling of a .BAT file Support 5
vefatica Strange behavior reloading SHRALIAS sav files. Support 1
J ASSOC / FTYPE strange error message Support 3
D Strange crashes in @CRC32 and @MD5 Support 9
Charles Dye Strange output, here-doc redirection, TYPE, //UnicodeOutput=Yes Support 6
S Strange CHKDSK behavior Support 6
vefatica Strange results with CP 1252 Support 12
S Strange REN problem - non-English characters Support 3
dcantor Strange status in ACTIVATE command Support 0

Similar threads