A swedish character sent through keystack gets converted

Jun 2, 2008
21
0
#1
TCC 9,02.154 Windows XP [Version 5,1,2600]
TCC Build 154 Windows XP Build 2600 Service Pack 3

When using swedish characters with keystack the output is wrong.
This is reproducible if you add swedish to Regional and Language
Options.

Use the following syntax from the command line to see what happens
(start notepad first):
activate "Untitled - Notepad" %+ if %_? ne 0 *beep || keystack /w36 "räksmörgås" enter "RÄKSMÖRGÅS"
å = key after p
ö = key after l
ä = key after ö
Shift is uppercase for all three.

The problem described above came with version 9 and is working in version 8.

Best regards
Berndt Berg
 
Jun 2, 2008
21
0
#2
TCC 10,00,32 Windows XP [Version 5,1,2600]
TCC Build 32 Windows XP Build 2600 Service Pack 3

When using swedish characters with keystack the output is wrong.
This is reproducible if you add swedish to Regional and Language
Options.

Use the following syntax from the command line to see what happens
(start notepad first):
activate "Untitled - Notepad" %+ keystack /w36 "räksmörgås" enter "RÄKSMÖRGÅS"
å = key after p
ö = key after l
ä = key after ö
Shift is uppercase for all three.

The problem described above came with version 9 and is working in version 8.

Best regards
Berndt Berg
 

rconn

Administrator
Staff member
May 14, 2008
10,436
95
#3
TCC 10,00,32 Windows XP [Version 5,1,2600]
TCC Build 32 Windows XP Build 2600 Service Pack 3

When using swedish characters with keystack the output is wrong.
This is reproducible if you add swedish to Regional and Language
Options.

Use the following syntax from the command line to see what happens
(start notepad first):
activate "Untitled - Notepad" %+ keystack /w36 "räksmörgås" enter "RÄKSMÖRGÅS"
å = key after p
ö = key after l
ä = key after ö
Shift is uppercase for all three.

The problem described above came with version 9 and is working in version 8.

Best regards
Berndt Berg
Are you using a Unicode font in both TCMD and TCC? (It definitely will not work with an ASCII font.)
 

rconn

Administrator
Staff member
May 14, 2008
10,436
95
#4
TCC 10,00,32 Windows XP [Version 5,1,2600]
TCC Build 32 Windows XP Build 2600 Service Pack 3

When using swedish characters with keystack the output is wrong.
This is reproducible if you add swedish to Regional and Language
Options.
This should be working in 10.0.35; try it and let me know if you still have any problems.