1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Accents in Spanish

Discussion in 'Support' started by oph, Feb 13, 2014.

  1. oph

    oph

    Joined:
    Jun 28, 2008
    Messages:
    25
    Likes Received:
    0
    Only a question:

    Windows 7 in Spanish, Take Command and TCC in Spanish.

    When I send the command dir to screen, I see (I edited the line,
    of course)

    dir

    El Volumen en disco D es HD103SJ-1 El número de serie es b895:dbd2
    Contenido de D:\*
    -----------8<--------

    But if I send the ouput to a file, I see

    dir >file

    El Volumen en disco D es HD103SJ-1 El n£mero de serie es b895:dbd2
    Contenido de D:\*
    -----------8<--------

    The accented u (ú) is seen as a pound sign (in Word, in Ultraedit,
    in Notepad ASCII codified, and more).

    The code page

    P gina de c¢digos activa: 850

    Of course, it must say

    Página de códigos activa: 850

    The same for filenames with accented vowels and Ñ (N+tilde).

    Can be solved this problem?

    Thank you.
     
  2. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,355
    Likes Received:
    39
    OPTION //UNICODEOUTPUT=YES might be what you're looking for...?
     
  3. oph

    oph

    Joined:
    Jun 28, 2008
    Messages:
    25
    Likes Received:
    0
    Yes, it works with text editors.

    Thank you.
     
  4. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,355
    Likes Received:
    39
    As long as your text editor supports UTF-16; most do.

    If you want to make this setting the default, type OPTION to open the configuration dialog, then select the "Startup" tab (the first one). The "Unicode Output" option is the third tick box from the top, in the column on the right.

    Incidentally, console programs like TCC use a different code page setting than Windows programs. You can see both settings by typing:

    Code:
    echo Windows: %@winapi[kernel32.dll,GetACP]  OEM: %_codepage
    
    You must capitalize "GetACP" just like that.
     
  5. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    10,029
    Likes Received:
    84
    Make sure that you're using a Unicode font (not a raster font!), and make sure you're using the same font in Take Command and TCC. Mixing Unicode and raster fonts will cause all kinds of problems with non-English characters.
     
  6. oph

    oph

    Joined:
    Jun 28, 2008
    Messages:
    25
    Likes Received:
    0
    The output follows:

    Windows: 1252 OEM: 850
     
  7. oph

    oph

    Joined:
    Jun 28, 2008
    Messages:
    25
    Likes Received:
    0
    I am using Anonymous Pro in Take Command and TCC, and in Ultraedit, too. No problems with accents, umlaut ä, or ß
     

Share This Page