How to? Any way to run a command in a new tab at startup?

May 2, 2012
25
0
Chicago USA
At least temporarily I'd like Take Command to start up with two tabs:
  1. The normal command shell
  2. In the other tab another program (let's say my editor)
I found nothing obvious in the Help, and a search here failed to turn anything up as well. Is this possible?
 
May 20, 2008
11,411
99
Syracuse, NY, USA
Option (menu) ... TakeCommand ... Tabs ... make tab 1 your normal shell ... make tab 2 your editor (or whatever you want).
 
May 2, 2012
25
0
Chicago USA
That didn't seem to work very well (at least on my second attempt). My first try failed because I forgot your vital instruction to "make tab 1 your normal shell." When I tried explicitly to make Tab 1 run TCC I managed to conflubulate the whole Take Command and it wouldn't run at all any longer. I just got the dreaded "Not Responding" spinning wheel of death. I had to edit my INI file to yank out those menu-made mods before I could run TCC again.

Perhaps I'll abandon the idea and just run my command in a new tab after TCC is up and running ... as I have been doing. I had hoped to automate it a bit, but it's not worth very much time/trouble. Maybe one more attempt.
 
Apr 2, 2011
1,441
10
54
North Carolina, USA
Maybe vince would like to capture the OPTION dialog about what a sample startup would be with te default shell and his editor in the 2nd tab. then tmaynard could change the paths / programs as necessary...
 
May 20, 2008
11,411
99
Syracuse, NY, USA
I don't have a console editor so I used FTP.EXE in my tests; it shouldn't matter. I can't imagine how this could go wrong.
upload_2014-8-10_19-56-0.png



upload_2014-8-10_19-57-3.png


TCMD starts with Tab 1 visible. After switching to tab 2 ...
upload_2014-8-10_19-59-31.png
 
May 20, 2008
11,411
99
Syracuse, NY, USA
All that looks like this when I view the INI file.
Code:
[Tab1]
Title=TCC16
Command=g:\tc16\tcc.exe /q
Directory=v:\
RunAs=
Password=
[Tab2]
Title=FTP
Command=c:\windows\system32\ftp.exe
Directory=v:\
RunAs=
Password=
 
May 2, 2012
25
0
Chicago USA
We should probably point out that the whole idea of starting your editor in a Take Command tab is probably completely pointless, unless it is a console-based editor. Most Windows editors aren't.
Hello? Vim? (Not GVim, but regular old console Vim.)

And I guess I should probably point out that if I were using Windows tools, I'd likely not be out on the command line in the first place -- but perhaps I should have a second cup of coffee on a rocky Monday morning before I post anything. :grumpy:

More to the point, I've tried emulating the suggested solution(s) and ended up with a scrogged TCC yet again. My own settings were:
  • Title: TCC 16.03
  • Command: C:\Program Files\JPSoft\TCMD16x64\tcmd.exe # With and without quotes
  • Directory: C:\Users\Tom.000
I chose to experiment "safely" by leaving TAB 1 blank and inserting the above into TAB 2. That failed miserably: I got only one tab (blank), and a non-responsive window. Ultimately, I could click/open a new tab and undo my changes (no manual editing of the INI required), but this simply isn't worth any more of my time.

My thanks to all who have responded. You are the giants upon whose shoulders I was unable to clamber up. Maybe next time. Thanks again.

Tom.
 
Last edited:
May 20, 2009
293
5
57
ITALY
...
My own settings were:
  • Title: TCC 16.03
  • Command: C:\Program Files\JPSoft\TCMD16x64\tcmd.exe # With and without quotes
  • Directory: C:\Users\Tom.000
...
If these are exactly Your settings, You should change from "tcmd.exe" to "tcc.exe", right now it seems that You are trying to run Take Command itself, so this might be the reason why it does not work.

Regards

Rodolfo Giovanninetti
 
Jun 2, 2008
359
4
That's definitely the problem. You're running the Take Command GUI, which is configured to run Take Command GUI in a tab, which is configured to run Take Command GUI in a tab, etc., etc., etc. tcc.exe is what gives you the console prompt.

but this simply isn't worth any more of my time.
Don't give up already! You just now provided the info needed to determine the problem. :smile:
 
May 2, 2012
25
0
Chicago USA
Don't give up already! You just now provided the info needed to determine the problem. :smile:
Well, I guess I forgot to mention that I did indeed change "tcmd.exe" to "tcc.exe" and it had absolutely no ameliorative effect whatsoever; exactly the same hang as before, and this time I had to edit the INI file (with Notepad (!)), and logoff/on in order to recover.

After a lifetime of battling dragons I endeavor whenever possible to keep my systems as vanilla as possible -- sickeningly so -- so I doubt that this is a configuration issue (but it certainly could be, I won't rule it out).

Edit: What started out as just a hare-brained idea has escalated into near Yak Shaving status, and it's now burning cycles in brains other than my own. I never meant for any of this to happen. Forgive me, please.
 
Last edited:
Jun 2, 2008
359
4
No worries. Most of us are here to help too, not just report problems. :) Hmm... It should be pretty straight forward, given you're not trying to run TCMD inside itself. Heh My last suggestions would be to maybe rename your .ini file out of the way and then you'll be starting from scratch settings-wise. Maybe reboot too..? I do PC support and that's necessary more often than people would like it to be.

Edit: spelling
 
Last edited:
May 2, 2012
25
0
Chicago USA
It should be pretty straight forward
Even you must see by now that that simply isn't true. But: I will go down fighting, if I must ... as long as I do my fighting on my own time, I suppose.

maybe rename your .ini file out of the way and...Maybe reboot to..?
While I have reverted back to my everyday, production INI file each time (the one that's been working just fine for at least a year), I have not hidden it completely -- except for when I need to recover from a truly major foul-up here lately.

And, I did my time in the Tier 1 Help Desk trenches as well, and then served in Tiers 2 and 3 before they finally ran out of Tiers to put me on (and I had run out of tears, too), so I recognize the value of "turning it off and back on again." In fact, I do this religiously each and every day. "Dirty tables" cause as many problems as "faulty wires" do: My system never runs 24 contiguous hours, but it's only just another hoop so why not jump through it, eh? I'll do both and report back but be advised that the priority for me to acquire this bogey has dropped to zero.

In fact, in just another day or two the need to fire up TCC with a mysterious something running in a second tab will have dissipated.

Oh, and @Charles Dye: I owe you an apology, of course. First, I was a bit snippy when I made my wisecrack -- even though I tried to admit it at the time. It was uncalled for, and I regret it. Second, upon reflection, the truth in your remark is ineluctable: All of this code is compiled and linked against Windows libraries -- where else would it ever run? -- and thus even the console code can legitimately be said to be "Windows programs" ... Metro, Desktop, Commandline, ..., what have you. Let me run and refill that coffee cup of yours. It is coffee, right?
 
May 29, 2008
47
0
Orion Arm, MWG
Will TCMD launch successfully with any true console app in its second tab? "Good" ol' CMD, for instance. If so, then I might tend to suspect something with your editor itself or a strange interaction between it and TCMD. (I'm assuming the editor loads without incident in a standalone instance of TCC.) If not, then...well, we'll have to keep looking for causes/answers. The folks here love a good TC*-related poser, even if your own interest is waning. Their success rate is very high.
 
May 2, 2012
25
0
Chicago USA
rename your .ini file out of the way and...reboot
And dang if that didn't work! I now have TCC running in Tab1 and <my secret> running right alongside in Tab2! AFAIK this only costs me a single tweak that I made manually to my INI file (to set <C-u> to be DelToBeginning). Obviously any other via-menu mods are also gone, but they can be restored as I notice their absence (Insert mode will be first! It always is.)

So thanks, TEA, for giving me that last-minute boost for yet one more attempt. And the fact that this time it worked really nags at me now: I must have made some silly little mistake on my earlier attempt. I've really don't nothing different (substantially speaking, that is) ... except probably configured it properly for the first time.

I will reveal the fact that my editor is not what I'm running in the second tab -- but no more! Actually, I do use Vim, and it's easy enough simply to have GVim running in another window and <M-tab> between the two, I wouldn't need console Vim in a second tab. It's all very hush-hush for now, I'm sorry.

Thanks again to all for the help, encouragement, and support. There is no "I" in "JPSoft" ... it's all about the team.
 
May 2, 2012
25
0
Chicago USA
Will TCMD launch successfully with any true console app in its second tab?
@vefatica demonstrated that fact early on ... with pictures ... so the existence of the grail had been proven. It was merely up to me to continue the quest to obtain it for myself.

[Aside: I realize that my @-signs are meaningless here on the forum, but they have a symbolism now that I hope is familiar everywhere.]
 
Jun 2, 2008
359
4
Cool, I'm glad you got it working!

Yup, @s are pretty universally recognized, even by this forum, so I find out by previewing this post.
Your @vefatica (<-and this) is clickable and takes you to his profile.
 
Similar threads
Thread starter Title Forum Replies Date
P Run as Admin tab in non-elevated Take Command session? Support 9
Jay Sage Command Will Not Run Using Short Name of Path Support 5
C How to? run a batch file in administrator mode while debugging in take command software Support 1
M Installed but can't run Take Command 16.0 Support 5
B Select and run lines from Command Input panel? Support 1
A How to? Run a TCC command from external program Support 2
M How to? Run a command (alias, actually) on a "timed" basis... Support 13
vefatica What limit have I run into? Support 9
S How to? Runs start /w in invisible mode OR run program after exit of another one Support 3
Peter Murschall BDEBUGGER "Run to Cursor" - where is it ? Support 1
Jay Sage Problem with Context Menu Copy+Paste+Run Key Assignment Support 7
D What does the file "..\Everything\Run history.csv" store? Support 5
dcantor How to? Can 32-bit TCC be run on a system with 64-bit TCMD and TCC installed? Support 6
G tcedit ist not run in tc 24 file explorer Support 10
A Windows 10 This app can't run on your PC Support 2
Roedy run as administrator Support 27
rps Documentation "Copy+Paste+run" question Support 2
Peter Murschall IDE/BDEBUUGER in TCC 22 didn't run Support 7
fpefpe How to? which will run? Support 1
C How to? run a BTM in elevated, inv tcc tab window Support 9
M How to? Run the control panel from a TCC session... Support 2
M How to? Run TCC from Windows Install DVD... Support 2
B Batch file won't run if there is already an instance of TC 17 running Support 9
P MS VS2013 vsdevcmd.bat fails to run with tcmd 17 x64 Support 10
redwdc btm won't run in ver. 17 but works in ver. 16 Support 11
Joe Caverly How to? Run DOS .exe's the same way Wine does... Support 3
vefatica Why isn't TCSTART.BTM run? Support 8
D Run all .CMD batch files with CMD.EXE Support 16
Joe Caverly Run As Administrator in TCMD16 Support 3
F Sending "Y" to chkdsk to run on C at next reboot Support 25
T tcc /c "[...]" fails when run from third party terminal Support 11
Jay Sage Specified INI File Refuses to Run Support 3
C How to? create a JPSoft BTM menu to run custom custom batch files Support 2
vefatica Coruption after which BTMs won't run Support 7
Joe Caverly Copy Paste Run Support 12
S Fixed TCC.EXE 13.03.47 won't run Support 4
Stefano Piccardi run as limited user Support 2
M How to? Windows 7 - run TCC as admin w/o UAC intercept Support 4
E TCC requires elevation to run Support 2
Jay Sage How to Run Non-Elevated From Elevated TCC Support 1
L How can I run tcmd in terminal window only? Support 13
S Run as Administrator question Support 3
Joe Caverly TCMD12 Beta Expired, TCMD11 will not run Support 7
p.f.moore Run as administrator from TCC Support 2
vefatica Help from IDE fails after a non-debug run Support 5
B TCC doesn't run using another user Support 2
A How to Run the 4NT 8.02 .INI Key Version Support 3
K double click to run btm? Support 2
D TCC won't run telnet on Windows 7 RC1 Support 5
D Can I use TC to run Cygwin? Support 4

Similar threads