AutoStart on Reboot

Dec 2, 2008
212
2
Canada
#1
AttachConsole.png
When trying to start TCMD at boot time, I get the above message, I click the "OK" button and TCMD shuts down. After the Windows reboot is complete, I can start TCMD with no problems.

I start TCMD at boot with key:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\Take Command 19.0 which contains C:\Program Files\JPSoft\TCMD19_x64\tcmd.exe

Ever since Windows 10 started locking thing down directories things haven't been working.

Any ideas?

Thanks
 
Jun 2, 2008
284
1
Newton, MA
#3
That message is an internal Windows error when TCMD tries to connect to the (hidden) TCC console window. That is going to be rather problematic before Windows has finished initializing everything.
I have that same problem on one of my computers. It seems that TCMD is starting up too quickly. Is there a way to delay its startup?
 
#4
Is there a way to delay its startup?
You could try starting it via a scheduled task (triggered by a logon). I have no idea if exactly when it happened would differ from using the registry's "Run" key.

You could also try putting a shortcut to it in the AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup folder. Again, I have no idea how that might compare to other methods.

Using any method, you could run a batch file which delayed and then started TCMD. I'm not sure, but I think the scheduled task method might allow the batch to be unseen.