can start TakeCommand 15.01 on Windows XP

May 31, 2008
382
2
(This post is related to a similar issue that I reported for TCCLE here http://jpsoft.com/forums/threads/tccle-and-windows-xp.4958/)
I installed TakeCommand 15.01 on the same Windows XP machine. Setup was OK, but TakeCommand can't start.
At the end of the installation, with the view Readme File dialog in the background, I got an Explorer (?) Move dialog that said, "Select the place where you want to move '\URLA5' then click the move button." which I did and found a new URL shortcut pointing to http://jpsoft.com/on-install-take-command.html. Then I clicked on Run Take Command and got tcmd.exe - Application Error. The application failed to initialize properly (0xc000001d). Click OK to terminate the application. I had to click twice to dismiss the dialog. Tried to run TakeCommand again and got exactly the same error message, and had to click twice to dismiss it.

The Application Event log includes the above error messages, and also two messages from MsiInstaller saying "Product: Take Command 15.01 -- Installation completed successfully."

What I notice about the specific PC where all this is happening is that it runs a disk protection sofware called Deep Freeze, which I'm not familiar with, and Internet Explorer 8.
 
May 20, 2008
3,515
4
Elkridge, MD, USA
Is it possible that you installed into a directory to which you do not have execute access? I have no trouble (in a Windows login with administrator privileges) starting any version of 4nt or tcc, from RUN, from shortcut icons or their hotkeys, or TCC command prompt. OS: WinXP Pro SP3 (32b).
 
May 20, 2008
3,515
4
Elkridge, MD, USA
Oh, try to disable Deep Freeze - "protective" software often protects you from using your own tools! Many builds of various versions of TCC.EXE were falsely detected by AVG as viruses, often a build giving false alarm, while immediately previous and subsequent builds did not. BTW, reports to AVG that it was a false alarm were always ignored, I had to manually add TCC to the "safe" list. While I don't blame antivirus software makers for occasional false alarms (it would be impossible for them to test every build of every program in the whole world, and all they can test for is patterns in code), but I do blame them for failing to respond to the false alarm reports.
 
May 31, 2008
382
2
Steve, I would disable Deep Freeze if I could but it's password-protected. Anyway, I tried downgrading TakeCommand until I found a version that can run on this PC. Version 14.03.59 can. None of the 15.00 and 15.01 series that I have available can. I tried as far back as version 15.00.14.
 
May 31, 2008
382
2
Steve, I would disable Deep Freeze if I could but it's password-protected. Anyway, I tried downgrading TakeCommand until I found a version that can run on this PC. Version 14.03.59 can. None of the 15.00 and 15.01 series that I have available can. I tried as far back as version 15.00.14.
Rex, if you're reading this, could you please confirm my conjecture of what's going on with this PC. It's an Athlon XP CPU and it doesn't implement the SSE2 instruction set, just SSE1. Do more recently compiled TakeCommand versions require SSE2 support? That would explain why this PC fails running TakeCommand with exception code 0xc000001d (illegal instruction). On the internet I found many forum posts that report this kind of issue for various products.
 

rconn

Administrator
Staff member
May 14, 2008
12,344
149
Take Command doesn't require SSE2. But I can't say what the third-party dll's or the VS 2012 RTL might be using. v15 uses VS 2012, so MS may have decided to drop support for old CPUs (as they did for XP). I'll see if I can confirm that with MS.
 
Similar threads
Thread starter Title Forum Replies Date
C TakeCommand 11 won't start Support 1
J Take command does not start on Windows 10 Support 3
N for start /b anamoly Support 1
U Can not get/start Take Command gui Support 1
DrusTheAxe START /? is incomplete Support 2
S How to? Runs start /w in invisible mode OR run program after exit of another one Support 3
vefatica Start/stop screensaver from TCC? Support 12
S START with title Support 4
vefatica START at 0,0? Support 2
D START /POS versus @WINPOS and @WINSIZE Support 12
vefatica START /elevated and PcaSvc? Support 5
S incorrect message at start Cancel batch job 4START.bat ? (Y/N/A) : Support 1
vefatica START /PGM "name with spaces.URL" fails Support 2
L Peculiarities of how START launches processes Support 15
R How to? START program as top window? Support 2
Peter Murschall v24 IDE/BDEBUGGER won't start Support 9
Dmitry L. Kobyakov WAD Start /pgm "name.htm" works improperly Support 4
Joe Caverly START Dialog usage of %_ variables Support 0
A Fixed [23.0.22]: TCMD crashes shortly after start, TCC keeps running in background Support 6
kb6ojs Want to start TCMD v20 with every Windows 10 bootup Support 3
vefatica START *command Support 5
Per TCC/LE 14 64-bit won't start on Windows 10 Insider Preview 17063 (171213) Support 12
A Fixed (CMD compat) START /D fails to recognize the switch option. Support 3
MikeBaas start /runas - I'd like /netonly Support 2
vefatica Start VIEW with the toolbar showing? Support 5
vefatica Documentation START /AFFINITY Support 0
B how to do in "start" command thing like in tcc.exe Support 1
J directory or folder to start in Support 2
R How to? Not have RT version show on start Support 3
D WAD START /ELEVATED "Title" /PGM "job.btm" Support 6
J How to? Start TCMD with different configurations Support 3
vefatica START /K ... Support 1
vefatica Documentation START /AFFINITY Support 5
vefatica Start TCMD with File Explorer showing? Support 2
Alpengreis WAD Each start/close of TCMD changes my Explorer setting Support 7
WadeHatler Just started getting a message about Cloud Storage every time I start TCC 19 Support 3
Alpengreis Fixed TCMD FileExplorer Start-Directory problem Support 4
vefatica Shortcut/start-up folder nonsense Support 20
fishman@panix.com Can I start TCC in full screen mode? Support 9
R Unable to start any BTM file from Explorer Support 5
fpefpe How to? Stange start up issue Support 1
M Start "/Elevated" failure... Support 3
vefatica START, CMD vs. TCC Support 0
Steve Pitts Difference in exection with and without START Support 24
rjperrella start /tabna leaves blank windows when running batch scripts Support 10
vefatica Start-up directory for new tabs? Support 7
C OT: Registry OPEN verb to start elevated... Support 2
tmaynard Error on Take Command Start after recent update Support 2
M How to? Start a program on log on elevated abovenormal Support 5
M How to? Start the version of Take Command that I want... Support 7

Similar threads