Can't access textpipeengine.dll

#1
Just upgraded to v14:

TCC 14.00.26 Windows XP [Version 5.1.2600]
TCC Build 26 Windows XP Build 2600 Service Pack 3
Registered to Peter Koves

When truing to use tpipe, I get (even in the TC directory; which for sentimental reasons is C:\4NT):

[[email protected]]C:\4NT>tpipe
TPIPE: Error - Can't access textpipeengine.dll

Looked at the permissions of the DLL and see nothing wrong there (Full Control). What could be the trouble?
 
#6
Does C:\Program Files\JPSoft\TCMD14x64\ need to be in the path for v and tpipe to work? I've never had it in my path, and I thought v used to work without it. At the moment, neither work.
I'm not sure, but the v14 install (32-bit, anyway) does put it in the path, I think so the TPIPE EXE can be found. I'm not up-to-date on the rules for locating DLLs.
 
#8
Not reproducible here -- can you post a directory listing of your installation directory?
Well, I guess you caught me:oops:. I did the install over an existing TC11 directory. I did some spring cleaning, removed all prugins from the path (verified with PLUGIN command), killed all copies of TCMD/TCC and SHRALIAS, restarted and still get the error.

BTW, V and VIEW work fine.

Below is the current contents of the directory:

2012-07-05 17:11 <DIR> .
2012-07-05 17:11 <DIR> ..
2012-07-05 17:09 <DIR> bak-dll
2012-01-27 13:05 <DIR> bak10
2012-07-05 07:53 <DIR> bak11
2012-01-27 13:05 <DIR> EditConfig
2012-01-27 13:05 <DIR> Extras
2012-07-05 08:00 5,328 aliases
2006-02-22 16:40 34,304 BorlndMM.dll
2012-07-03 20:55 621,712 English.dll
2012-07-03 20:55 407,184 EnglishD.dll
2008-02-19 23:36 20,342 examples.btm
2012-07-03 20:55 658,576 French.dll
2012-07-03 20:55 412,816 FrenchD.dll
2009-10-28 02:57 70 ftp.cfg
2011-12-10 11:37 616 functions
2012-07-03 20:55 657,552 German.dll
2012-07-03 20:55 412,816 GermanD.dll
2012-07-05 17:10 7,384 histlog
2012-07-03 20:55 3,686,912 ide.exe
2012-06-06 23:29 1,033,984 ipworks9.dll
2012-06-06 23:39 408,832 ipworksssh9.dll
2012-06-06 23:36 1,028,864 ipworksssl9.dll
2012-06-06 23:16 165,632 ipworksssnmp9.dll
2012-06-06 23:14 747,264 ipworkszip9.dll
2012-06-19 21:54 2,315,584 IsLicense50.dll
2012-07-03 20:55 648,336 Italian.dll
2012-07-03 20:55 410,256 ItalianD.dll
2012-06-29 16:52 9,469 license.txt
2012-07-03 20:55 296,080 onig.dll
2012-06-29 16:52 7,324 readme.txt
2012-07-03 20:55 683,152 Russian.dll
2012-07-03 20:55 411,792 RussianD.dll
2012-07-03 20:55 647,824 SciLexer.dll
2012-07-05 17:11 3,873 setenv.btm
2012-07-05 17:11 139,351 setenv.zip
2011-04-29 15:19 2,717 setenv_2011-04-29_15-19.btm
2011-08-26 21:43 2,711 setenv_2011-08-26_21-43.btm
2012-01-08 15:35 4,188 setenv_2012-01-08_14-35.btm
2012-07-03 20:55 40,592 ShrAlias.exe
2012-07-03 20:55 654,992 Spanish.dll
2012-07-03 20:55 414,352 SpanishD.dll
2000-01-24 06:01 453,632 stdvcl40.dll
2012-07-03 20:55 1,480,368 TakeCmd.dll
2012-07-03 20:55 253,376 tcc.exe
2009-12-28 13:15 1,000 tccbatch.btm
2009-12-28 13:17 1,168 tcchere.btm
2009-12-28 13:17 1,270 tcctabhere.btm
2012-07-03 19:16 3,486,830 tcmd.chm
2012-07-03 20:55 3,954,752 tcmd.exe
2012-07-05 08:21 5,221 tcmd.ini
2008-05-03 13:21 1,090 tcmdbatch.btm
2009-12-28 13:17 1,202 tcmdhere.btm
2009-12-16 10:47 1,164 tcstart.btm
2012-04-18 21:17 6,210,048 textpipeengine.dll
2012-07-03 20:55 121,056 TPipe.exe
2012-07-03 20:55 528,016 updater.exe
2012-07-04 23:33 346 updater.ini
2012-03-03 12:15 368,729 v.chm
2012-06-29 16:55 2,239,080 v.exe
2012-07-03 20:54 249,856 WiFiMan.dll
 

rconn

Administrator
Staff member
May 14, 2008
10,575
97
#11
When truing to use tpipe, I get (even in the TC directory; which for sentimental reasons is C:\4NT):

[[email protected]]C:\4NT>tpipe
TPIPE: Error - Can't access textpipeengine.dll

Looked at the permissions of the DLL and see nothing wrong there (Full Control). What could be the trouble?
The most likely reason is that your system is blocking the COM registration (textpipeengine.dll is a COM dll). Try running "regsvr32 textpipeengine.dll" from the command line and see if you get an error message.
 
#12
The most likely reason is that your system is blocking the COM registration (textpipeengine.dll is a COM dll). Try running "regsvr32 textpipeengine.dll" from the command line and see if you get an error message.
Looks like that was it. The good news is that running regsvr32 command produced a dialog stating that the registration succeeded and now afterwards, TPipe works. Many thanks!