1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't print to Acrobat X Standard printer

Discussion in 'Support' started by David Marcus, Jan 13, 2012.

  1. David Marcus

    Joined:
    Jun 4, 2008
    Messages:
    646
    Likes Received:
    1
    I just installed Acrobat X Standard on two machines, one Vista Home Premium 32 bit, the other 7 Home Premium 64 bit. In Take Command, I do File > Print and select the Adobe PDF printer. Other than the CPU briefly increasing, nothing happens on either machine. I can print to Adobe PDF from other apps, e.g., Firefox, Excel.

    TCC 13.03.38
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    I don't have Acrobat Standard here to try, but Take Command is just sending the buffer to Windows to print. So it's got to be either a Windows problem or (more likely) a limitation of the PDF printer. Either way, it's unlikely that I can do anything in Take Command to affect it.
     
  3. David Marcus

    Joined:
    Jun 4, 2008
    Messages:
    646
    Likes Received:
    1
    OK. FYI, I just tried some more apps: notepad, Lugaru's Epsilon, Eudora, and IE. All printed to the Adobe PDF printer without a problem. So far, TC is the only app I've found that has the problem.
     
  4. TEA-Time

    Joined:
    Jun 2, 2008
    Messages:
    282
    Likes Received:
    1
    In case you can't figure this out, maybe try the freeware PDFCreator at pdfforge.org.
     
  5. David Marcus

    Joined:
    Jun 4, 2008
    Messages:
    646
    Likes Received:
    1
    I've already got PDF995 installed, and TC prints fine to that. Anyway, I rarely want to print to PDF from TC. I was just reporting a bug. When I installed Acrobat X, the first thing I tried to print to it to see if it was working was TC. So, it took me a little while to realize the problem was with TC, not Acrobat.
     
  6. TEA-Time

    Joined:
    Jun 2, 2008
    Messages:
    282
    Likes Received:
    1
    Ah.. gotcha.
     
  7. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    I downloaded the evaluation version of Acrobat X Pro, and traced through the code. Everything is working in TCMD up to the point where it sends the buffer off to Windows, but it doesn't appear in Acrobat.

    Take Command (like every other Windows app) has no idea what a printer driver is doing; it just sends text to the device context and it's up to Windows and the printer driver to handle it.

    However, since every other printer driver I'm aware of works with TCMD, as do a couple of third-party PDF drivers I tried, it would seem to be a problem either in Windows or Acrobat. (More likely the latter, given the thousands of bug reports about the Adobe PDF driver I found in a couple of minutes on Google.) At any rate, there's nothing that I can do to "fix" it; the best I could hope for is changing random things to see if they had any effect. I added it (to the bottom) of my "to do" list.
     

Share This Page