WAD cmd.exe under tcc doesn't find apps

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Apr 29, 2009
35
0
Redmond, WA
#1
Seen this before? Could there be some setting I have wrong in TCC? Hoping it's not a bug.

1. Run tcc
2. From prompt run cmd
3. Try to run a program found in directory or path without specifying file extension
Expected: runs
Actual: error msg

This is breaking running other 3rd party batch scripts that call cmd.exe to run apps, like the nodejs npm module. Running cmd.exe from Start > Run works fine, finds apps without specifying extension, error occurs only when cmd is run from within tcc

 
#2
Hi,
No problem here, but I am running a newer release than you are. I am on 32-bit OS.

Joe
Code:
[C:\Windows\System32]ver
 
TCC  15.01.51  Windows Vista [Version 6.0.6002]
 
[C:\Windows\System32]whoami
optiplex9601\jlc
 
[C:\Windows\System32]cmd
Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.
 
C:\Windows\System32>whoami
optiplex9601\jlc
 
C:\Windows\System32>
 

rconn

Administrator
Staff member
May 14, 2008
10,164
86
#4
Not reproducible here.

This is definitely not a TCMD or TCC issue -- unless you've found a catastrophic bug in the Intel hardware and the Windows OS security model. The parent process does not (cannot!) affect the child process's file search & execution behavior; CMD is talking straight to the Windows APIs and TCC is totally uninvolved. (Unless you're running plugins that are intercepting APIs?)

It's far more likely that you've got a different environment / registry / etc. configuration in the native TCC window vs. the CMD window. Try starting a CMD window, then run TCC, then CMD, and see if you get the same behavior.
 
#5
Found the issue. In my tcstart.btm I had a line like this to add some extensions to the executable paths:
set pathext=%pathext%,.py,.rb
Worked fine in TC, but when dropping to cmd.exe from TC, cmd.exe got overwhelmed. Removing the %pathext% fixed the issue. Thanks to everyone for quick and thorough replies.