CMDEBUG and New Shell

#1
I am using;
upload_2017-10-6_19-41-3.png

On the View menu, there is an option at the bottom, New Shell... F7, which does the same thing as the New Shell icon on the toolbar.

On the Options menu, I have TCC Syntax selected.

Without TCMD 18 or TCC 18 running, and only CMDebug running, launched from the Windows 7 Start Menu, when I select New Shell, I am presented with the CMD.EXE window.

Ditto with TCMD 18 or TCC 18 running.

If I launch CMDebug from the TCC 18 window, and select New Shell... F7 from CMDebug, I am presented with the TCC.EXE (version 18.00.32)

If I launch CMDebug from the TCC 21 window, and select New Shell... F7 from CMDebug, I am presented with the TCC.EXE (version 21.01.53)

I have TCC-RT installed, and I would like to use TCC-RT with CMDebug.

When I run the following .BTM;
Code:
echo %_startpath
echo %_4ver
echo %_tccrt
it returns;
Code:
echo C:\Program Files\JPSoft\CMDebug21
C:\Program Files\JPSoft\CMDebug21
echo 21.01
21.01
echo 0
0
...which means CMDebug is not using TCC-RT. I'm pretty sure that I have my system setup to use TCC-RT for .BTM files;
Code:
c:\users\jlc\utils>assoc .btm
.btm=TCCRT.Batch
Is this all WAD? How do I get CMDebug to use the TCC-RT?

Joe
 

rconn

Administrator
Staff member
May 14, 2008
10,597
97
#2
CMDebug will never use TCC-RT, because it doesn't need to.

The F7 / New shell option will start whatever is in COMSPEC as an interactive shell. You can't run TCC-RT as an interactive shell, so you'll never be able to get it with the new shell option.

CMDebug has TCC-RT built in, so that's what it runs (internally) when you debug a batch file. It won't identify itself as %_tccrt, because it's running in the debugger.