CMDebug, dark theme, current line

ron

Aug 19, 2008
151
0
Maybe something out of your control, but the 'current' line background color using either dark theme is not ideal. v 26.01.38

Is there a setting I'm overlooking?

1589048010794.png
 
May 20, 2008
10,621
81
Syracuse, NY, USA
I don't know how similar CMDebug is to IDE.EXE but in IDE.EXE, I use "VS 2015 Dark" and I see this.

1589050774298.png


I did a lot of customizing and I don't remember how I got that background for the current line. That color is 0x00404040 (4210752) which I can't find in IDE's registry settings.
 

ron

Aug 19, 2008
151
0
Well, I was wondering if I'd misspoke. I'm technically using bdebugger in TCMD and I just assumed the core components would be similar to CMDebug. So yeah, checking my title bar against yours, I'm using IDE 26 too.
 
May 20, 2008
10,621
81
Syracuse, NY, USA
Ron, what build of the product do you have; is it old? I have "TCC 26.01.38 x64". I complained about the current line background color back in TCEdit in February. Maybe Rex made a change.
 

ron

Aug 19, 2008
151
0
See my first post, same as yours and x64. But I left out a very important detail. Hit F5 - start the debugging session. While not debugging I have the same current-line background you have.

So to be precise, it's the current line background while stepping through a debugging session.
 
May 20, 2008
10,621
81
Syracuse, NY, USA
See my first post, same as yours and x64. But I left out a very important detail. Hit F5 - start the debugging session. While not debugging I have the same current-line background you have.

So to be precise, it's the current line background while stepping through a debugging session.
Same here ... not crazy about it.

1589063017744.png
 
  • Like
Reactions: ron