Command-line Editing Shortkeys That Fail

Aug 28, 2008
127
4
I've been trying to improve my command-line editing prowess in TakeCommand and have found a few of the shortcuts on the help reference don't work. I find the following four don't do anything:

  1. Undo (Alt + Z)
  2. Redo (Alt + Y)
  3. Delete the argument to the left of the cursor (Ctrl + Alt + L)
  4. Delete the argument to the right of the cursor (Ctrl + Alt + R)
I've checked the keyboard settings (using the OPTION) command and found they all seem to be set correctly. It seems anything involving the Alt key fails, and I wonder whether that's got something to do with Windows gobbling it up. I'm running the latest version of TakeCommand on Windows 10, the following being the output of the "ver /r" command.

TCC 27.01.23 x64 Windows 10 [Version 10.0.19042.985]
TCC Build 23 Windows 10 Build 19042

Thanks in advance for any help.
 
Aug 28, 2008
127
4
I confess I tested only with the left Alt and Ctrl keys, and they don't work. Using the right Alt key seems to be ignored completely in that not only does Alt + z fail to undo, it actually inserts a 'z'.
 
May 20, 2008
11,801
118
Syracuse, NY, USA
With the settings below, all four of the keystrokes you mentioned work in TCMDv27 running TCCv27 if I use the left Ctrl and Alt..

1622066568072.png
 
Aug 28, 2008
127
4
Aha! Now we are getting somewhere. All these years into using TakeCommand (since v1.x when I migrated from 4DOS), and I never realized I could control which of those let's-invoke-the-Windows-menuing-system keys were allocated to the command-line editor code versus the application-level code. Nice! I find I can now use the keyboard shortcuts as intended. Thank you for that.

I have one remaining issue: the undo/redo functionality doesn't seem to work as I'd expect with the newly possible options to delete arguments using Ctrl + Alt + (L|R). For example, when I call up a previous command line (by typing a few characters and the up arrow) and hit Ctrl + Alt + L, it properly deletes the last argument immediately to the left of the cursor, which appears at the end of the line by default. But when I then press Alt + Z to undo that, I get something completely unexpected. It does not undo the deletion of the argument to the left, it undoes the command line recovery from the history.

I see how if I type my few characters and hit the up arrow to restore a previous command to the editing buffer, I have to hit Alt + Z twice to undo that restoration. So maybe there are a couple of issues left to iron out? Thanks so much for all the help thus far. This is going to be very helpful for my command-line editing.
 

Similar threads