1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Documentation Comspec not working

Discussion in 'Support' started by trad, Mar 21, 2013.

  1. trad

    Joined:
    Mar 17, 2013
    Messages:
    11
    Likes Received:
    0
    According to your FAQ we can change the default command processor. I changed it to the following and rebooted.

    "C:\Program Files\JPSoft\TCMD15x64\tcmd.exe"

    Yet clicking on a batch file in Explorer still runs up cmd.exe What am I doing wrong?

    Note: I tried this with TCC/LE on a different computer too and got the same results. All computers are Win7-64 based.


    Code:
    2. How do I change the default command processor?
     
    You can change the default command processor by going to the Control Panel / System / Advanced System Settings / Advanced / Environment Variables, and changing the value of "ComSpec" in the System Variables window.
     
    For example, in v14 you'd change it to something like: c:\program files\jpsoft\tcmd14\tcc.exe depending on where you installed TCMD & TCC.
     
  2. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,287
    Likes Received:
    39
    It sounds like you want to change a file association, not the default command shell. Try running the batch file TCCBATCH.BTM in the program directory. (I recommend that you associate .BTM files with TCC, but leave .BAT and .CMD alone; they are probably best run in CMD.EXE.)
     
    trad likes this.
  3. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    Another important point: The command processor is tcc.exe; tcmd.exe is the tabbed console interface. You may run any console program, including tcc.exe and cmd.exe in a tcmd tab. You can run multiple instances of both command processors in different tabs of the same instance of tcmd.
     
  4. trad

    Joined:
    Mar 17, 2013
    Messages:
    11
    Likes Received:
    0
    Yes, this fixed it... Thanks...
     

Share This Page