CTRL-C in V10

#1
Hello everyone,

I must be missing something, but this is odd. In v10 build 34 and build 32 (the 2 I have installed), CTRL-C does not seem to break commands.

For example, ping -t 127.0.0.1 won't stop and I've had to kill the TCC session. Did something change? I've tried it with the "Cancel Batch File on Ctrl-C" option on an off thinking this might have an effect, but it didn't make difference. ESC also does not work.

I've searched the forums and read the release note, but couldn't seem to find anything on this so I thought I would ask.

Thank you.

Michael
 

rconn

Administrator
Staff member
May 14, 2008
10,506
94
#2
Hello everyone,

I must be missing something, but this is odd. In v10 build 34 and build 32 (the 2 I have installed), CTRL-C does not seem to break commands.

For example, ping -t 127.0.0.1 won't stop and I've had to kill the TCC session. Did something change? I've tried it with the "Cancel Batch File on Ctrl-C" option on an off thinking this might have an effect, but it didn't make difference. ESC also does not work.
Fixed in build 37. (You may need to delete your existing v10 shortcuts.)
 

rconn

Administrator
Staff member
May 14, 2008
10,506
94
#4
Juanma Barranquero wrote:

> ---Quote (Originally by rconn)---
> Fixed in build 37. (You may need to delete your existing v10 shortcuts.)
> ---End Quote---
> I still see this problem with 10.00.41. Ctrl-C works in a detached TCC.EXE, but as soon as I attach it to TCMD, it stops working.
Did you go to the registry and delete your existing v10 key shortcuts?
(The easy way is to delete the entire v10 tree; remove \HKCU\Software\JP
Software\Take Command 10".)

Until you do that, ^C is going to be used as a Copy accelerator.

Rex Conn
JP Software