Ctrl-D alias no longer works

Mar 17, 2011
2
0
#1
Hi,

I've been using the alias

@@Ctrl-D=exit

for a long while now to simply end the shell window by pressing ctrl-d. This worked up to TCC 11, but in 12 it seems not to work...is there a setting I've missed somewhere or has keystroke handling changed?

Thanks,
ken1
 
Aug 9, 2009
133
0
#2
try this
@@Ctrl-D=exit^r




> -----Original Message-----
> From: ken1 [mailto:]
> Sent: Friday, 18 March 2011 1:53 a.m.

> Subject: [Support-t-2681] Ctrl-D alias no longer works
>
>
> Hi,
>
> I've been using the alias
>
> @@Ctrl-D=exit
>
> for a long while now to simply end the shell window by
> pressing ctrl-d. This worked up to TCC 11, but in 12 it seems
> not to work...is there a setting I've missed somewhere or has
> keystroke handling changed?
>
> Thanks,
> ken1
 
Aug 9, 2009
133
0
#3
Also check NormalKey directive in WhatEver.INI file


> -----Original Message-----
> From: ken1 [mailto:]
> Sent: Friday, 18 March 2011 1:53 a.m.

> Subject: [Support-t-2681] Ctrl-D alias no longer works
>
>
> Hi,
>
> I've been using the alias
>
> @@Ctrl-D=exit
>
> for a long while now to simply end the shell window by
> pressing ctrl-d. This worked up to TCC 11, but in 12 it seems
> not to work...is there a setting I've missed somewhere or has
> keystroke handling changed?
>
> Thanks,
> ken1
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,586
46
Albuquerque, NM
prospero.unm.edu
#5
I've been using the alias

@@Ctrl-D=exit

for a long while now to simply end the shell window by pressing ctrl-d. This worked up to TCC 11, but in 12 it seems not to work...is there a setting I've missed somewhere or has keystroke handling changed?
Control-D is used, by default, to delete the currently displayed line from the command history. You can use a NormalKey=Ctrl-D directive in TCMD.INI to unassign this key.