Ctrl-End doesn't work. DelToEnd is not executed

Sep 10, 2009
33
0
#1
I just updated from version 12.0 to 18.0. Know Ctrl-End (DelToEnd) doesn't work any more.

It doesn't work in the simple TCC console window and event not in the TC window.

Also defining it in the INI file doesn't solve it.

[4NT]
DelToEnd=Ctrl-End

Edit:
Ctrl+Pos1 and Ctrl+End now cause a scroll of the screen buffer to the top and to the end. I Don't want this. How can I stop this behaviour and get the same edit behaviour like in CMD.EXE.
 
#2
I don't see this on my installation, Ctrl+Home and Ctrl+End delete to the beginning and to the end.
I used to redefine some keys myself, but I am not doing it anymore, because I had to redo it at each new major version installed.
I could be that the problem comes from some information carried over from v12 to v18. You could try to start TCC with the /I option, to disable processing of initialization files.
 
Aug 19, 2009
17
0
#5
I am also experiencing the same problem, with Ctrl-End no longer deleting from the current cursor position to the end of the line.

In a possibly related problem, I cannot select text in Take Command v18 by holding down the Shift key and pressing the arrow keys. The tab title changes to include the word 'Select' but nothing actually gets selected, and when I subsequently type characters they do not replace the supposedly selected text.
 
Sep 10, 2009
33
0
#6
@Chris Wilcock:
Yes. I have these problem too. Selecting text pressing the shift key isn't possible any more.
When I open a "normal" TCC Console it works. (Green button in the icon). In the Take Command Window with the tabs, it doesn't work and I see the "Select" text in the Tab.
 
Aug 19, 2009
17
0
#7
Martin, what version of Windows are you running this on? I am running on Windows 10 Pro.

The curious thing is, I have this on two Windows 10 64-bit PCs, and one is OK and the other is not. I cannot see any configuration differences between the two PCs, and they are both running the exact same version of Take Command - version 18.00.29.

Very odd...

Chris
 
Sep 10, 2009
33
0
#8
@Chris: Windows 10 Enterprise. I currently have only one machine with TCC 18.00 and Windows 10.
The other machine inclusive my private one (desktop/laptop) are using Windows 10 but TCC/LE 14.00 and the console version doesn't seam to have the problem.
 
#9
Same here ...

- Ctrl-End (del-to-end) = no function (TCMD & TCC).
- Shift-CursorRight (selecting) = works NOT in TCMD, works in TCC

Clean install of Win 10 Pro x64 with clean install TC 18.00.31 x64 ...
 

rconn

Administrator
Staff member
May 14, 2008
10,746
97
#10
@Chris Wilcock:
Yes. I have these problem too. Selecting text pressing the shift key isn't possible any more.
When I open a "normal" TCC Console it works. (Green button in the icon). In the Take Command Window with the tabs, it doesn't work and I see the "Select" text in the Tab.
Not reproducible here (Win 10 x64). There isn't any code in TCC or TCMD that puts "Select" in the tab -- perhaps you've toggled one of the new Win 10 console editing options?
 
Aug 19, 2009
17
0
#12
Are you running Windows 10? Conhost in Win 10 is eating the Ctrl-Home and Ctrl-End keys and TCC never sees them.
Hello Rex

I think I have found a solution to both of the problems in this thread, thanks to your information about Conhost eating keys. I came across this article, which you are no doubt aware of, and edited a couple of the registry settings listed at the end of the article.

https://blogs.windows.com/buildinga...ovements-in-the-windows-10-technical-preview/

Here's a screenshot of what happens when I press Shift-Left after typing 'echo hello' on the PC with the problem. As you can see, the word 'Select' has appeared in the tab, but there is no selection highlighted, and if I then type some more characters they appear at the end of the line, rather than replacing the 'o' in 'hello'

select.png

If you close Take Command, navigate to the HKCU\Console key in the registry and change the following two registry values, Shift-arrow text selection and Ctrl-End will both work as expected once again:

CtrlKeyShortcutsDisabled = 1

ExtendedEditKey = 0

Please note that the article incorrectly names this last value as 'ExtendedEditKeys' - it's named with a non-pluralised version in the registry.

Chris
 

ron

Aug 19, 2008
146
0
#14
Indeed, thanks for creating this thread. Saved me from certain insanity :-)

Odd that Rex could not reproduce it on Win10x64 - unless he already had those settings unchecked and didn't realize/remember.

Ctrl-End.png