Debugger menu absent

Jun 20, 2011
10
0
Take Command v25.00.21 x64 -- From the Tools menu, I choose Edit/Debug and then Open
Windows 10 [Version 10.0.17763.805]

1571089197985.png


I end up with two instances on the taskbar:

Window 1.
1571089874064.png

A sea of black there

Window 2.
1571090020037.png

The debugger without the menu
 

Attachments

Jun 20, 2011
10
0
That didn't work. So, I tried deleting the entire JP Software key, and that didn't work either. So I uninstalled and reinstalled Take Command. That didn't work either.

Other ideas?
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,188
72
Albuquerque, NM
prospero.unm.edu
I notice that there's a "Menu Bar" option in the Customize dialog:
Customize-dialog.png


I can't actually change the setting, though. Clicking on the little box just makes a twinkle noise.
 

rconn

Administrator
Staff member
May 14, 2008
11,894
133
The menu is in EnglishD.dll. Assuming that file isn't corrupted, the menu creation & display is all handled by Microsoft's code; why it isn't displaying on your system (and works on everybody else's?) is a mystery.

Are you running any screen managers that might be intercepting the output?

Do you get the same result when you run "BDEBUGGER" from the TCC command line?
 
Jun 20, 2011
10
0
I'm running DisplayFusion Pro 9.5, which is a multi-monitor utility. But on another of my machines with both TCMD and DisplayFusion installed, same versions, the debugger menu displays just fine.

Exiting DisplayFusion also makes no difference.

Yes, BDEBUGGER gets the same result.

I could flatten this machine and reinstall everything, but that would be a lot of work. I could run Windows update, but that could result in a lot of work.

I'm thinking I'm going to live with this for now. I might try uninstalling Take Command and then deleting the installation folder in Program Files, then deleting everything in the registry that say JP Software, and then see what happens when I reinstall. Maybe sometime later this week or next.