1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Debugsession must not turn hidden objects on.

Discussion in 'Support' started by Ruud Uphoff, Feb 15, 2016.

Tags:
  1. Ruud Uphoff

    Joined:
    May 22, 2013
    Messages:
    21
    Likes Received:
    0
    HI,

    System is Windows 10, 64 bits, november 2015
    TCC is version 19.02.39

    Each time I start a debug session, all hidden files (not system) are made visible.

    Any idea how to get rid of it?
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,860
    Likes Received:
    83
    I don't know what you mean -- "made visible" where?

    And what do you mean by starting a debug session - do you mean starting BDEBUGGER (the IDE)?
     
  3. Ruud Uphoff

    Joined:
    May 22, 2013
    Messages:
    21
    Likes Received:
    0
    H,
    See picture below. I Use "Don't show hidden file, folders, or drives.
    A session with BDEBUGGER switch that into "Show hidden files, folders, and drives.
    This should not happen.



    Image1.jpg
     
  4. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,955
    Likes Received:
    30
    I can reproduce it.
     
  5. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,955
    Likes Received:
    30
    Indeed, when IDE starts,

    Code:
    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Hidden
    changes from 2 to 1. When IDE exits, it changes back. Using F5, you can see it in an Explorer window.

    Even if you have the hidden Explorer setting, you see hidden files in IDE's File\Open dialog.
     
  6. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,860
    Likes Received:
    83
    The IDE turns on "show extensions" and "show all objects" in the Windows shell, and resets them to their original values when it exits. This was requested by many users (and has behaved this way for 10+ years). You're the first user to request it be changed back -- you can submit a request to the feedback forum for an option to disable it.
     
  7. Alpengreis

    Joined:
    Jan 12, 2014
    Messages:
    229
    Likes Received:
    6
  8. Alpengreis

    Joined:
    Jan 12, 2014
    Messages:
    229
    Likes Received:
    6
    OKAY: I was probably wrong: I see: the Advanced Options from TCMD affects the ...

    ShowHiddenFiles=No

    and NOT the ...

    ShowSysFiles=No
    ShowSuperHidden=No

    ... this was my problem - at least it seems so - I'll check it out and report here soon ...

    EDIT: yes, I was confused with those different options! It works right! And yes, also here I need a restart of TCMD to see the effect in File Explorer from TCMD (nevertheless the option changes immediately)!
     
  9. Ruud Uphoff

    Joined:
    May 22, 2013
    Messages:
    21
    Likes Received:
    0
    Aha..
    It seems I am not as decent as expected. Hidden files remain visible, because sometimes, I just click the windows close icon [X].
    But thanks to vefatica for the registry entry I was searching for. Now, if hidden remains visible, I just click al small batch with a reg add command.

    Thanks
     
  10. Alpengreis

    Joined:
    Jan 12, 2014
    Messages:
    229
    Likes Received:
    6
    Is there any chance to avoid this behaviour after close Icon [X]?
     
  11. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,955
    Likes Received:
    30
    Here, there is no problem using the "X". It does reset "Don't show hidden ...". If you have an expolrer window open at the time, you must refresh it (F5) to see things become hidden again after X-ing BDEBUGGER.
     
  12. Alpengreis

    Joined:
    Jan 12, 2014
    Messages:
    229
    Likes Received:
    6
    Ok, that's good news, thank you very much!
     

Share This Page