Disable global hotkey Ctrl+Shift+T

Apr 3, 2013
2
1
#1
I've looked here in forum and searched help file, but didn't find anything about it. Is there an option to disable global hotkey Ctrl+Shift+T that moves Take Command from taskbar to system tray?
 
Likes: Michael Geary

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,629
46
Albuquerque, NM
prospero.unm.edu
#2
I've looked here in forum and searched help file, but didn't find anything about it. Is there an option to disable global hotkey Ctrl+Shift+T that moves Take Command from taskbar to system tray?
Open your .INI file in a text editor, for example:
Code:
notepad "%_ininame"
Search for a line beginning with TrayHotKey. If you find one, change the value after the equals sign to a forward slash; if not, add a line TrayHotKey=/ somewhere in the [TakeCommand] section. Then restart TakeCommand.
 
Likes: Michael Geary
May 30, 2008
214
1
#3
The default hot-key choice is perhaps a little unfortunate.

Got quite confused as to why "undo-close-tab" stopped working in Firefox until I connected the dots.
 
Likes: Michael Geary
Apr 3, 2013
2
1
#4
Open your .INI file in a text editor, for example:
Code:
notepad "%_ininame"
Search for a line beginning with TrayHotKey. If you find one, change the value after the equals sign to a forward slash; if not, add a line TrayHotKey=/ somewhere in the [TakeCommand] section. Then restart TakeCommand.
DOH! How did I miss that?!? :oops:
 
Apr 11, 2013
5
1
#6
It would be better to not set any global hotkey at all than to take over Ctrl+Shift+T, especially with no way in the UI to turn it off. This is a really poor default setting. Ctrl+Shift+T is an important key combination in every modern browser. No program should take it over globally.

Imagine a program taking over Ctrl+Z - taking away Ctrl+Shift+T is a lot like that. It's a safety line you grab when you just made a mistake, and that's not something you want to have mysteriously fail.

Sorry I'm cranky! It took me a while just to figure out that it was Take Command causing this. So I do thank you for posting the solution.
 

X A

Oct 29, 2012
11
0
#7
It would be better to not set any global hotkey at all than to take over Ctrl+Shift+T, especially with no way in the UI to turn it off. This is a really poor default setting. Ctrl+Shift+T is an important key combination in every modern browser.
I agree. Unfortunally this comment blog by someone on JPSoft's addressed the problem soon enough, but appears to have been ignored.
 
Jul 4, 2010
8
0
#8
+1 for this being a terrible choice for a default hot key, since every web browser uses it to reopen the last tab. And no documentation, and no UI to control it!
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,629
46
Albuquerque, NM
prospero.unm.edu
#11
Rex, any chance you could get this fixed so that TCMD isn't overriding a frequently used keyboard shortcut?
You can reassign it or disable it yourself. Edit the .INI file, and find (or create) a line beginning with TrayHotKey=

Set it to any alphanumeric to make the hotkey Control-Alt-whatever. Set it to a slash (or probably most other punctuation -- I haven't tested) to disable it.
 
#12
I realize that. I'm just tired of having to deal with it whenever I'm on a new machine/install. Plus, as Rex has repeatedly said, we're not supposed to edit the INI.

At this point I'm back to using %@iniwrite to just fix it since I can do that reasonably universally since I do have a standard TCSTART.BTM that I deploy to my VM test environments.
 

rconn

Administrator
Staff member
May 14, 2008
10,597
97
#15
What does it use for TrayHotKey? ("What's New" still says "Ctrl-Shift-T".)

Ctrl-Shift-Z.

When I press Ctrl-Shift-T, I get a new tab ... why? What key combo is supposed to give a new tab?
Apparently you've defined it yourself -- there is no default key combo in TCMD to create a new tab.
 
#16
Neither Ctrl-Shift-T nor Ctrl-T is mentioned in my INI file ... or in any alias ... or in any global hotkey (my own server). But either of them opens a new tab in TCMD.

Ctrl-Shift-Z works as expected with "Tray=Yes". But with "Tray=No", Ctrl-Shift-Z **hides** TCMD (it disappears without a taskbar icon). Is that WAD?
 
#17
Ctrl-Shift-Z works as expected with "Tray=Yes". But with "Tray=No", Ctrl-Shift-Z **hides** TCMD (it disappears without a taskbar icon). Is that WAD?
There's a peculiar interaction with the Win7 tray's hide/show/icon/notifications control. Even after TCMS has been closed, its icon remains in that control (with a defunct caption) and affects the behavior of future TCMDs. That caption is not updated in the control for quite a while. I have not started/closed TCMD several times and an old caption still appears there. Are you destroying the tray icon when TCMD is closed? I don't think it should remain in that control.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,629
46
Albuquerque, NM
prospero.unm.edu
#18
Neither Ctrl-Shift-T nor Ctrl-T is mentioned in my INI file ... or in any alias ... or in any global hotkey (my own server). But either of them opens a new tab in TCMD.

Take Command shortcut keys are stored in the registry, under (I think) HKCU\Software\JP Software\Take Command mm.nn\Settings\NormalLayout\Shortcuts. The key data is stored in a single binary item, not as friendly ASCII key names, and clearly isn't meant to be viewed or edited. But I think you could rename or delete the key while TC isn't running to reset all of your shortcut keys in one swell foop.
 
#19
Take Command shortcut keys are stored in the registry, under (I think) HKCU\Software\JP Software\Take Command mm.nn\Settings\NormalLayout\Shortcuts. The key data is stored in a single binary item, not as friendly ASCII key names, and clearly isn't meant to be viewed or edited. But I think you could rename or delete the key while TC isn't running to reset all of your shortcut keys in one swell foop.
I renamed the key with TCMD not running. When I started TCMD Ctrl-T and Ctrl-Shift-T still caused a new tab to start.
 
#20
Interesting ... the registry contains nearly identical trees under "Take Command 15.0" and "Take Command 15.01". When I renamed the "Shortcuts" sub-sub-subkey of "Take Command 15.0" it was re-created. When I renamed the same in "Take Command 15.01" it was not re-created. (Neither changed the behavior of Ctrl-T and Ctrl-Shift-T.) Does TCMD need both trees?