WAD Each start/close of TCMD changes my Explorer setting

#1
After each start or closing of TCMD changes my Explorer setting ...

"Geschützte Systemdateien ausblenden (empfohlen)"
"Hide protected operating system files (Recommended)"

to DISABLED or as second effenct (saw this after a start of TCMD elevated) after start to DISABLE and after exit to ENABLED again ...

I MUST have enabled this always and it's my decision not a program decision ;-)

It seems it's similar to another thread with IDE, but here it's even without IDE ...

https://jpsoft.com/forums/threads/debugsession-must-not-turn-hidden-objects-on.7189/#post-41195

PS: v19.10.43 x64
PPS: Your forum seems buggy again, cannot save each 2nd time an edited post ...
 

rconn

Administrator
Staff member
May 14, 2008
10,785
97
#2
After each start or closing of TCMD changes my Explorer setting ...

"Geschützte Systemdateien ausblenden (empfohlen)"
"Hide protected operating system files (Recommended)"

to DISABLED or as second effenct (saw this after a start of TCMD elevated) after start to DISABLE and after exit to ENABLED again ...
WAD - go to the TCMD menu "OPTIONS / Take Command / Advanced" and look for the "Show Hidden Files" option.
 
#3
Rex, my setting is to show hidden files in both programs Windows Explorer and TCMD.

Nevertheless TCMD does right now after start deactivate show hidden files system wide - and after quit enable again.

And TCMD does NOT react to a change in TCMD, Options, Advanced ... so I can tick on or off, NO EFFECT ...

And last but not least: for testing purposes, I have set Windows Explorer now to NOT show hidden files and yep, here too, a change in TCMD, Options, Advanced has no effect ...

I had another effect earlier (today) but NOW: TCMD does ALWAYS disable hidden files on start, REGARDLESS of setting ...

So: NOW I cannot have "open TCMD WITH hidden files", impossible!

Here must be something wrong ... maybe IDE has influence too because I had used it today too ... or with my Win 10 x64 ...

PS: I'm not sure anyway if this is a good idea to have a setting within TCMD Options, why not in Windows Explorer only?
 
Last edited:
#5
That TCMD option works here, but not upon "Apply" or "OK". After TCMD is restarted, I see whichever option (show/not show hidden files) I chose.
Strange ... option switch in TCMD works here whithout a TCMD restart but has no effect - even not after a system reboot. And as you can see in my original posting, I had first another effect. I don't know why this has changed but I know that I had changed the related option in Windows Explorer while TCMD was open and I used IDE, else no idea ...
 
#6
Strange ... option switch in TCMD works here whithout a TCMD restart but has no effect - even not after a system reboot. And as you can see in my original posting, I had first another effect. I don't know why this has changed but I know that I had changed the related option in Windows Explorer while TCMD was open and I used IDE, else no idea ...
IDE does turn on showing hidden files and as far as I know there's no way (yet) to avoid that.
 
#8
OKAY: I was probably wrong: I see: the Advanced Options from TCMD affects the ...

ShowHiddenFiles=No

and NOT the ...

ShowSysFiles=No
ShowSuperHidden=No

... this was my problem - at least it seems so - I'll check it out and report here soon ...

EDIT: yes, I was confused with those different options! It works right!