Fixed Echo randomly activated in script

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Aug 16, 2008
124
0
#1
In the following snippet, echo is randomly activated (in this case on the fifth iteration):
Code:
@echo off

do index = 1 to 1000
    :: disable audible beep for input
    option //BeepLength = 0
    echo ``

    echo %index
    delay 1
enddo
Loop, index, and delay are just to demonstrate the issue.

This is the latest TCC version.
 

Attachments

Aug 16, 2008
124
0
#3
It's stripped down from a "shell selector" batch script:
Code:
@echo off
setlocal & setdos /g., /x0
on errormsg quit 1
on break quit 1
unalias * & unfunction *

set config_=%@path[%_batchname]%@name[%_batchname].ini

:: disable audible beep for input
option //BeepLength = 0

cls /c
echo Enter shell
echo  [1] TCC
echo  [2] TCC/LE
echo  [3] Cmd
echo  [4] PowerShell
echo  [5] Fish
echo  [6] Zsh
echo  [7] Bash
echo ``

inkey /k"1234567" Shell:  %%selection_

echo ``
iff     %selection_ == 1 then
    gosub READ_CONFIG Tcc

    cls /c
    tcc /q
[...]
 
Aug 16, 2008
124
0
#4
"echo ``" s the equivalent of "echo." in TCC according to the documentation. It just echoes an empty line (in case I misinterpreted Rex' question).