Error when attempting to launch "Safe in Cloud"

#1
I have a password-storage app ("Safe in Cloud") that wouldn't open this way at the TCC prompt:

c:\apps\safeincloud> safeincloud

or

c:\apps\safeincloud> start safeincloud

A dialog appeared, containing an error message about an illegal instruction (I should have copied it; alas, I didn't). So I tried:

c:\apps\safeincloud> cmd /c safeincloud

That did work. Afterward, trying to launch the program in the first two ways shown above began working as expected.

What might I be seeing here? Possible Windows bug? Possible SafeInCloud bug? Possible TCC bug?
 
#2
Might there be an issue with the size of the environment? Both ways you tried to start safeincloud from TCC pass it the total TCC environment; START /I safeincloud would not. But starting CMD from TCC and from CMD probably does, too, so I may be barking up the wrong tree.

Did you check if starting a new TCC instance, or logging out and back in, or restarting your computer got the launch failure back? It would give a clue at what level the illegal instruction is used...