1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Everything broke … everything

Discussion in 'Support' started by vr8ce, Jun 17, 2015.

  1. vr8ce

    Joined:
    Jun 16, 2009
    Messages:
    13
    Likes Received:
    0
    … well, maybe not everything, but everything related to CD'ing around.

    TCC 18.00.18 on Win7 SP1.

    When I installed my initial eversion of 18, i.e. 18.00.17, I had it install Everything as part of the install. I played with it for a bit, and quickly decided it wasn't for me.* I then saw that build 18 was out, so I updated. In installing the update, I told it not to install Everything. I stopped the service, etc., so that the build 18 install could continue unimpeded.

    Build 18 is now installed, no Everything, no entry in TCMD.INI for Everything at all, but CDD still doesn't search the index. I've confirmed the jpstree.idx file is still there, and TCMD17 (release 17, not build 17) still works fine, i.e. cdd "something" brings up a list of all the "something" directories immediately.

    The "Extended Directory Search" option in the option dialog is set to 2, just like on release 17, and the path is empty, just like it is on release 17.

    So, what new thing do we have to do to get CDD using jpstree.idx again in release 18?


    *First, it uses the equivalent of 3, not 2, and I hate 3. When I do a "cdd foo", I want to find directory foo and foo only, not foobar, not toefoo, not football, just foo.
    Second, it only works on local NTFS, and I'm on a VM, so all my files are on "shared" devices, even though they're physically on the same laptop.
    Third, it introduces needless complexity for something that has worked great for years (decades?). (Is this a TC* problem or an Everything problem? Where and how do I create the index? Which do I tell where to put the index? Why is there no "Everything" option in the Option dialog? And so on and so on and so on.)
     
  2. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,017
    Likes Received:
    0
    You need to edit your INI file to add

    EverythingSearch=No

    to the [4NT] section. And remember to edit the file without TCMD/TCC running.
     
  3. vr8ce

    Joined:
    Jun 16, 2009
    Messages:
    13
    Likes Received:
    0
    Wow. Thanks for the reply.

    I would consider that a bug on several levels. By choosing NOT to install Everything, and taking a default install, the install broke what was previously working. That is a very large "no no".

    First, the default of having no entry should be the same behavior as the previous release ("least surprise), i.e. no entry should be the same as N.
    Second, the entry should be in the .INI at installation. IOW, the default .INI should have the entry in it, and the value should No unless Everything was installed as part of the installation.
    Third, there should be a way to affect the entry through the option dialog without having to manually edit the INI.
     
  4. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,017
    Likes Received:
    0
    @Rex - any thoughts about adding EverythingSearch= True/False to the Option dialogs?
     

Share This Page