everything.exe .vs. new installs

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Apr 13, 2010
195
2
57
The Hague
#2
I have the same problem.

During each install everything.ini is overwritten. One of the apparently default values is "run_as_admin=1" which causes the access permission dialog to appear after every reboot.

Please advice.

Best regards, DJ
 
Last edited:
Jul 29, 2016
36
1
#3
Usually I just keep a backup copy of my everything.ini file in a different directory, so I can copy it back to %appdata%\Everything\ later. After an upgrade, it seems like Everything Options does not default to using %appdata%\Everything\ for storing its .INI file. I make sure I have a backup of the .INI first, then I choose the option to use the %appdata%\Everything path and then hit OK, then I completely exit out of Everything (File -> Exit, not just simply clicking on the X), then copy my backup .INI file back and overwriting the new one just created by Everything, then starting Everything again (everything /o). Everything should be back again, although you might need to "Force Rebuild" the database again, and also double check that the "Run at startup", "Run as administrator", and "Run as service" options are set back to the way you want them.
 
#5
A fresh installation doesn't install a TCMD.ini. It is generated later on (when starting TCMD).
Apparently this [title] didn't do the trick.

In the installer script there are some possibilitie to fix this. The easiest one would be:
Install everything.ini.ORG (instead of everything.ini) and create a custom action: if not exist everything.ini copy everything.ini.ORG everything.ini (translated to batch)