Extended directory search - cure by renaming tcmd.ini

Jan 25, 2011
As previously, Extended Directory Search decided to stop working. I was able to cure the problem by renaming tcmd.ini to something else. I notice that there is also a file called updater.ini in the same directory. I am uploading the renamed INI file here - what is wrong with it?


_John Sampson_


  • TCMD.ini.sav.INI
    956 bytes · Views: 91

Charles Dye

Super Moderator
Staff member
May 20, 2008
Albuquerque, NM
I doubt there's anything wrong with your .INI file; the problem probably lies in your JPSTREE.IDX file. I'd try deleting that instead, then recreating it with CDD /NJ /S dir dir dir.... specifying only the locations you really want to index, not your entire hard drive.


Staff member
May 14, 2008
As previously, Extended Directory Search decided to stop working. I was able to cure the problem by renaming tcmd.ini to something else. I notice that there is also a file called updater.ini in the same directory. I am uploading the renamed INI file here - what is wrong with it?

Do you have a dual monitor display with the primary monitor on the right? (You've configured your popup CDD window to position its left edge at pixel -1260.)

There is always a file called updater.ini; it's used by the autoupdater.
Jan 25, 2011
In Version 18, Extended Directory Search went wrong as it has done previously, failing to find any folders. I deleted jpstree.idx and it worked again. Why does jpstree.idx prevent Extended Directory Search from working? Where is the index hidden?
Apr 2, 2011
North Carolina, USA
You can find he path either by

echo %@option[TreePath]


Option -> Command Line tab, Extended Directory Search > Path.
Jan 25, 2011
I have not found the "Everything Search" checkbox. But I have made "Extended Directory Search" work. The Command Line tab from Options | TCC has a box labelled "Path:" which is empty. Entering the path to jpstree.idx which I found using another product solved the problem. In my case the path was "C:\Users\User\Appdata\Local\JPSoft"
Jan 25, 2011
Replying to myself - wrote too soon. Extended Directory Search not working now after Windows reboot. Path still appears where I typed it. jpstree.idx still exists. EDS seems temperamental.
Jan 13, 2013
I'm going to update this thread by replying. extended directory search has stopped for me, also.

win 10 64-bit
tcmd 20.00.14 64-bit
single monitor
deleting jpstree.idx, cdd /s \
Still does not work.

I'm out of ideas
Aug 3, 2016
Isn't this because of Everything.ini gets overwritten with an update?

TCMD.ini indicates he is using Everything for extended direcory searches (EDS).
Deleting TCMD.ini creates a fresh version where EDS will default to the own internal database instead of Everything and thus bypasses the original problem
Similar threads
Thread starter Title Forum Replies Date
fishman@panix.com HELP!! I just updated to Version 28 and as usual I cannot make extended directory search work. Support 2
G Extended directory search not working Support 4
J Extended directory search has stopped working Support 9
J Initialise; Alias; Extended directory search Support 2
J Extended directory search - spaces in names Support 5
vefatica Disable extended directory searches (completely)? Support 8
vefatica Extended directory searches? Support 6
fishman@panix.com Extended Directory Searches are not working for me in CDD Support 9
C See if a file name matches extended range. Support 15
gschizas Fixed Cannot use extended path to delete invalid file Support 3
M Problem with Extended Search and non-ASCII characters in directories names Support 3
S Problem with extended wildcards Support 1
Y TCDIALOG extended Support 1
C extended DIR syntax? Support 7
J Extended support Support 0
rconn Extended Support keys sent Support 0
D How to use multi-line DO to loop through first level directory names Support 5
D ParentDirectory does not update directory history Support 6
samintz CDD to non-existent directory hangs Support 2
gworley rd (Remove Directory) gives interesting error: Support 2
D Directory History Window with wildcard search Support 3
D How to? Skip removing directory (RMDIR) without error message Support 2
gentzel Directory stack empty when running TCEXIT? Support 9
M WAD "Pictures" directory is empty in TCC but not in CMD or Explorer Support 4
G Local Directory Corruption Support 11
Jay Sage Directory Alias Access to FTP Servers Support 2
Joe Caverly DIRectory Colorization in v25 Help File Support 0
K copy changing destination current directory Support 1
thorntonpg option /u not working The directory name is invalid Support 5
J built in file explorer - how do i go back "up" the directory? Support 2
Joe Caverly Using a Directory Alias with @iniwrite fails Support 14
A Installer /extract: extracts into current directory if target not exists Support 12
Charles Dye Ctrl-Shift-Up doesn't update directory history Support 1
CWBillow Editing in the root directory of windows 10 Support 6
D Directory stack empty Support 1
J directory or folder to start in Support 2
M How to unlock a directory Support 1
Alpengreis Fixed TCMD FileExplorer Start-Directory problem Support 4
R V19 - At startup, TCC save directory in the directory history list Support 2
C Touch command — I Need to touch matching files in another directory. Support 5
nickles Move takecommand.18.0.key location to installation directory Support 4
vefatica TCMD's current directory? Support 4
J How to set working directory Support 10
nickles How to? Follow a JUNCTION type directory link Support 9
Steve Pitts WAD Strange output from DEL of a non-existent directory Support 7
I tab completion with directory commands Support 7
vefatica Start-up directory for new tabs? Support 7
cgunhouse Problem with CALL and Directory Aliases in V17 Support 9
vefatica FFIND /S, find directory with specified name? Support 7
David Wilbanks How to make new tab open in same directory as previous tab? Support 4

Similar threads