1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Extended directory search - cure by renaming tcmd.ini

Discussion in 'Support' started by jsampsontheumpteenth, Mar 7, 2012.

  1. jsampsontheumpteenth

    Joined:
    Jan 25, 2011
    Messages:
    31
    Likes Received:
    0
    As previously, Extended Directory Search decided to stop working. I was able to cure the problem by renaming tcmd.ini to something else. I notice that there is also a file called updater.ini in the same directory. I am uploading the renamed INI file here - what is wrong with it?

    Regards

    _John Sampson_
     

    Attached Files:

  2. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,286
    Likes Received:
    39
    I doubt there's anything wrong with your .INI file; the problem probably lies in your JPSTREE.IDX file. I'd try deleting that instead, then recreating it with CDD /NJ /S dir dir dir.... specifying only the locations you really want to index, not your entire hard drive.
     
  3. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,812
    Likes Received:
    82
    Do you have a dual monitor display with the primary monitor on the right? (You've configured your popup CDD window to position its left edge at pixel -1260.)

    There is always a file called updater.ini; it's used by the autoupdater.
     
  4. jsampsontheumpteenth

    Joined:
    Jan 25, 2011
    Messages:
    31
    Likes Received:
    0
    In Version 18, Extended Directory Search went wrong as it has done previously, failing to find any folders. I deleted jpstree.idx and it worked again. Why does jpstree.idx prevent Extended Directory Search from working? Where is the index hidden?
     
  5. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,012
    Likes Received:
    0
    You can find he path either by

    echo %@option[TreePath]

    or

    Option -> Command Line tab, Extended Directory Search > Path.
     
  6. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,812
    Likes Received:
    82
    Unless you are using Everything Search, jpstree.idx is *required* for extended directory searches.
     
  7. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,012
    Likes Received:
    0
    And remember there is the "Everything Search" checkbox on the Startup tab of Options.....
     
  8. jsampsontheumpteenth

    Joined:
    Jan 25, 2011
    Messages:
    31
    Likes Received:
    0
    I have not found the "Everything Search" checkbox. But I have made "Extended Directory Search" work. The Command Line tab from Options | TCC has a box labelled "Path:" which is empty. Entering the path to jpstree.idx which I found using another product solved the problem. In my case the path was "C:\Users\User\Appdata\Local\JPSoft"
     
  9. jsampsontheumpteenth

    Joined:
    Jan 25, 2011
    Messages:
    31
    Likes Received:
    0
    Replying to myself - wrote too soon. Extended Directory Search not working now after Windows reboot. Path still appears where I typed it. jpstree.idx still exists. EDS seems temperamental.
     
  10. drrob1

    Joined:
    Jan 13, 2013
    Messages:
    18
    Likes Received:
    0
    I'm going to update this thread by replying. extended directory search has stopped for me, also.

    win 10 64-bit
    tcmd 20.00.14 64-bit
    single monitor
    deleting jpstree.idx, cdd /s \
    Still does not work.

    I'm out of ideas
    Thx
     
  11. MaartenG

    Joined:
    Aug 3, 2016
    Messages:
    355
    Likes Received:
    8
    Isn't this because of Everything.ini gets overwritten with an update?

    TCMD.ini indicates he is using Everything for extended direcory searches (EDS).
    Deleting TCMD.ini creates a fresh version where EDS will default to the own internal database instead of Everything and thus bypasses the original problem
     

Share This Page