Extended Directory Searches are not working for me in CDD

#1
I have FuzzyCD=3 and TreePath=c:\users\harvey\appdata\local\jpsoft\. I run cdd/s to create jpstree.idx and then typing a target directory name followed by a \ just gives me a nastygram that TCC: (Sys) The system cannot find the path specified. What might I be doing wrong? The target directory definitely exists because I can reach by going the long way.

Harvey
 
Jan 10, 2013
7
0
#2
I have the exact same problem on my Win7 OS desktop but it does not have this on my Win8 desktop.
I noticed also cdd /s c:\ fails too.

Indexing c:\
TCC: (Sys) The filename, directory name, or volume label syntax is incorrect.
"C:\*"
 
#3
Edit your INI file while outside of TCMD / TCC and add

EverythingSearch=No

to the [4NT] section....

To see the full path of the INI file

Code:
C:\Program Files\JPSoft\TCMD18_x64]echo %_ININAME
C:\Users\Galloway\AppData\Local\JPSoft\TCMD.INI
 

rconn

Administrator
Staff member
May 14, 2008
10,551
97
#4
I have the exact same problem on my Win7 OS desktop but it does not have this on my Win8 desktop.
I noticed also cdd /s c:\ fails too.

Indexing c:\
TCC: (Sys) The filename, directory name, or volume label syntax is incorrect.
"C:\*"
Not reproducible here. But if you're using Everything Search, the "CDD /S" output is ignored (and thus a waste of time).
 

rconn

Administrator
Staff member
May 14, 2008
10,551
97
#5
I have FuzzyCD=3 and TreePath=c:\users\harvey\appdata\local\jpsoft\. I run cdd/s to create jpstree.idx and then typing a target directory name followed by a \ just gives me a nastygram that TCC: (Sys) The system cannot find the path specified. What might I be doing wrong? The target directory definitely exists because I can reach by going the long way.
What version of TCC and Windows are you using?
 
Jan 10, 2013
7
0
#7
TCC 18.00.19 x64 Windows 7 [Version 6.1.7601]
I can see that the jpstree.idx is created where the option window states in the Extended Directory tree (fuzzydir=3). When I type cdd doc or cdd Documents it fails but these are in the jpstree.idx file.
I have the cddpath set to %userprofile

cdd /s c refreshes the jpstree.idx so that part works.