Filename completion, internet files

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,383
39
Albuquerque, NM
prospero.unm.edu
#1
Attempting to download the latest build from the command line, I was unable to use filename completion. Thought I'd found a new bug; nope, just a configuration error. I had UnixPaths=NO. Fixed that, everything worked as expected.

Suggest that whenever file completion is attempted on an internet file, i.e. anything beginning with xxx:// then forward slashes should be handled as if UnixPaths=YES, regardless of the current setting.
 
#2
Charles Dye wrote:
| Suggest that whenever file completion is attempted on an internet
| file, i.e. anything beginning with xxx:// then forward slashes
| should be handled as if UnixPaths=YES, regardless of the current
| setting.

Concur.
--
Steve
 

rconn

Administrator
Staff member
May 14, 2008
10,100
85
#3
Attempting to download the latest build from the command line, I was unable to use filename completion. Thought I'd found a new bug; nope, just a configuration error. I had UnixPaths=NO. Fixed that, everything worked as expected.

Suggest that whenever file completion is attempted on an internet file, i.e. anything beginning with xxx:// then forward slashes should be handled as if UnixPaths=YES, regardless of the current setting.
Only possible if you don't have additional forward slashes in the name; i.e. something like:

ftp://jpsoft.com<tab>

would work but

ftp://jpsoft.com/tcmd/foo<tab>

would be incomprehensible to the parser.

Of course, if you could get everybody to use the correct syntax and put spaces before their switch characters, it'd be easy to implement.