Functions which no-one has ever tried to use....

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,466
88
Albuquerque, NM
prospero.unm.edu
@IPPORT and @IPZONEID. It looks like neither one has ever worked, and nobody has ever noticed.

@IPZONEID is funny. It seems to be picking up the IPv6 scope correctly, and then returning it as an error code. If adapter #0 has an IP address ending in %12, then @IPZONEID emits an "access code is invalid" error, and so on.

@IPPORT looks like it's about 99% there. Pass it a valid service name like "http" or "imap4" or "gopher", and it returns ... without changing the string buffer, so you just get the same string back. But an unknown service name gives an error message. So I think the code is requesting and getting the required data from Windows, and then blissfully exiting.

If both functions were removed and de-documented, I doubt if anyone would notice that, either. Priority: Iron your shoelaces first.
 
May 20, 2008
11,415
99
Syracuse, NY, USA
Hmmm! I get this.
Code:
v:\> echo %@ipzoneid[0]
TCC: (Sys) An attempt was made to load a program with an incorrect format.
 "%@ipzoneid[0]"
 
May 20, 2008
11,415
99
Syracuse, NY, USA
How do I find out? IPCONFIG /ALL shows only the "6TO4" adapter as having an IPV6 address.

And what's "%11"? All the IPV6 addresses I've seen look like that below.

Off topic, but I hope someone can shed some light ... I have two internet connections, neither of which have IPV6 bound.
upload_2017-12-9_0-0-45.png

But I see it in use (to whom else but Google). From NETSTAT -ano ...
Code:
TCP    [2002:48e6:5495::48e6:5495]:58831  [2607:f8b0:4006:819::2002]:443  ESTABLISHED
TCP    [2002:48e6:5495::48e6:5495]:58833  [2607:f8b0:4006:810::2003]:443  ESTABLISHED
TCP    [2002:48e6:5495::48e6:5495]:58835  [2607:f8b0:4006:813::200e]:443  ESTABLISHED
I also see IPV6 DNS info cached when I use "IPCONFIG /DISPLAYDNS".
Does anyone know what's going on?
 
May 20, 2008
11,415
99
Syracuse, NY, USA
@IPZONEID is rather fun. I get a different error message for each parameter I give it.
Code:
v:\> echo %@ipzoneid[0]
TCC: (Sys) An attempt was made to load a program with an incorrect format.
 "%@ipzoneid[0]"

v:\> echo %@ipzoneid[1]
TCC: (Sys) The access code is invalid.
 "%@ipzoneid[1]"

v:\> echo %@ipzoneid[2]
TCC: (Sys) Incorrect function.
 "%@ipzoneid[2]"

v:\> echo %@ipzoneid[3]
TCC: (Sys) The data is invalid.
 "%@ipzoneid[3]"

v:\> echo %@ipzoneid[4]
TCC: (Sys) Not enough storage is available to complete this operation.
 "%@ipzoneid[4]"

v:\> echo %@ipzoneid[5]
TCC: (Sys) The system cannot find the drive specified.
 "%@ipzoneid[5]"
 
Similar threads
Thread starter Title Forum Replies Date
A Problem with functions @int @decimal and identifying Powershell as a shell. Support 12
Joe Caverly "Functions" in cmd.exe batch files Support 6
vefatica Library functions and line continuations? Support 4
Charles Dye Documentation Help Nits Forever: Checksum functions Support 0
Joe Caverly SETLOCAL removes Aliases and Functions Support 3
Joe Caverly @NAME supports library functions Support 2
vefatica WHICH and @functions Support 2
vefatica Two @FUNCTIONs/aliases with the same name Support 4
M Keywords for commands, functions, internal variables Support 3
C Documentation near or fully obsolete functions Support 7
Charles Dye Optional F parm in checksum functions Support 0
C coding functions and subroutines Support 9
rps Functions @year[date] @isowyear[date] help Support 7
mikea How to? TCC and XMLnodes/XMLxpath functions Support 0
Dan Glynhampton Are these two functions the same? Support 2
M How to? Logic in functions... Support 5
A WAD function return values with parentheses prevent evaluation of additional functions Support 31
M "History" command not giving me what I want when executed by @Exec... functions... Support 6
Charles Dye Web help on functions Support 2
samintz Help examples for the @ISxxx functions Support 3
R specific functions for number conversion Support 2
C Unsuppressable errors from XML functions Support 5
nikbackm Checksum functions Support 4
J TCC Out of memory with aliases and functions Support 5
Peter Bratton Disappearing functions Support 1
A I dont see anything in the alias/functions/batchvariables tabs in IDE Support 13
dcantor Comments and suggestions on functions for binary buffers Support 4
J History file load hangs if file has complete garbage in it... Support 1
Peter Murschall TCC V26.01.3x Debugging has problems with Alias /R Support 1
Peter Murschall CMDebug 26.01.37 has problems with Alias Support 21
D TCC has much more elegant ways for usebackq. What ways? Support 12
D Pasting Unicode data has different behavior on TCC and CMD Support 2
D [cosmetic] Shortcut for v24 still has v23 in its comment Support 1
D Envar _tcexit has value, even with /IX startup parameter Support 0
C "Take Command has stopped working" Support 1
C "TakeCommand has stopped working" Support 3
R Fixed set /r has stopped working in build 35 Support 4
D Help index has GUNZIP Support 0
samintz WAD @format has issues in v18.00.14 Support 10
D Fixed @FORMATNC has changed. Support 6
D Fixed Dir /Nm:n has changed Support 1
V Fixed CD ~ has trash characters in it Support 5
vefatica Has NthArgument changed? Support 7
S Documentation KEYSTACK - has this feature been dropped? Support 5
forbin Fixed OSD /C has no effect Support 14
H Documentation Help for head has ... Support 0
D Documentation @ISPUNCT has rogue links Support 2
J Extended directory search has stopped working Support 9
old coot TC DIR command has trouble on my SSD Support 2
vefatica WAD TPIPE.EXE has stopped working Support 13

Similar threads