Handle WM_WHEEL when hiword(wparam) is less than WHEEL_DELTA

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Sep 1, 2008
See: http://blogs.msdn.com/oldnewthing/archive/2003/08/07/54615.aspx

I assume this is the problem I'm having. The MS Mice when the Intellimouse drivers are installed send updates smaller than WHEEL_DELTA.

This is causing tcmd to shoot the scrollbar to the top when I try to wheel.

This is a problem in 9 and 10, and is the primary reason I'm not upgrading to 10 - since it's the primary thing I was hoping would be fixed. I'm guessing I'm probably the first person to complain about it. :)

One might say: just install those stupid drivers, the os already handles the mouse fine! To which I say - the drivers have 1 great feature - the ability to map mouse buttons to keystrokes on a per-application basis, which I use heavily with Visual Studio. So that's not an option. Unfortunately it doesn't let me map wheel scrolling to keystrokes to work around this.