Help needed with TCC / LM command line

#1
Hello

When I invoke a TCC/LM command line session TCC.EXE the window title by default shows as
Administrator:title - command name

even if I do it from a batch where I give the window a title (e.g. Title My Window) I still get
Administrator:My Window

then any commands I issue in that session (e.g. dir) I see the window title change to
Administrator:My Window - dir.

The problem I have is I need the window title not to change. If I issue a title command all I want is that for the window title.

I have down stream functinality that is predicated on specific window titles. This always worked fine for me with earlier versions for 4NT (up through v6) now we are using Take Command/LC with Windows 7 - 32bit and encountering this problem.

I have search for and can't find any settings to surpress this.

BTW, if the command I invoke is a 16bit dos command it works fine its only when its a 32bit command like CMD or a resident command like DIR that I see this behavior

thanks
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,575
46
Albuquerque, NM
prospero.unm.edu
#2
You can prevent TCC from changing the title by turning off the "Update Titles" option, near the center of the "Startup" tab of the OPTION dialog. Once you've done that, you can set whatever title you like using the TITLE command and TCC won't update it. (Other programs might. CMD.EXE certainly will; but why on earth would you want to run CMD.EXE within TCC?)
 
#3
Thanks Charles and that has helped somewhat but I still have the user: infront of the window title. Also I have lots of legacy processes that get invoked (some of them are 16bit DOS apps) and when that occures the titles are changing again. This was never an issue using 4NT before and as I said we are new to using TCC/LE. Thanks again
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,575
46
Albuquerque, NM
prospero.unm.edu
#4
Really? Here, turning off UpdateTitles and setting a new title with the TITLE command prevents that. Is it possible that your "legacy processes" are starting a transient copy of CMD.EXE? Or do you perhaps have a TITLEPROMPT environment variable?

Of course you can try going back to 4NT, but I doubt that will make any difference; what you're seeing is normal Windows 7 UAC behavior. Disabling UAC might work around your problem, but that might be a case of the cure being worse than the disease....