History and TPipe Oddness

Jun 6, 2009
19
0
Sorry for the long message. I've been using TakeCommand for many years now, but lately I'm seeing some weird behavior with history, recall (up arrow) and tpipe.

On the Command Line options tab, I have checked [Move to End] and selected the [Save Last] radio button under Command History.
I have also specified a location for history2.log.

I started with a clean history file and ran the following commands (note: NB. is followed by a comment).

> tcc: NB. Alias for my local TCC config folder.
> type somefile.txt
> history NB. The above two commands are displayed as expected.
> tcc:
> type somefile.txt
> history NB. Everything displays normally and no duplicates commands are displayed.

Now the weirdness starts.

> type somefile.txt | tpipe /dup=0,0,1,100,0,0 NB. Remove duplicate lines from somefile.txt and it works as expected.

But now the history is all screwed up. In particular, duplicates have reappeared. Also, the tpipe line does not show up when I try the up arrow.

To make matters worse, a copy of TakeCommand seems to persists in memory after I exit. At least, that's what the Task Manager says. I can tell that something funny is going on because my laptop (a brand new Dell Precision Workstation) starts to heat up.

After I make sure that TakeCommand is no longer running and restart the shell, I check the history and confirm that duplicates have reappeared. Now if I repeat a command and check the history, once again duplicates are correctly removed. In fact, as long as I avoid the command that includes tpipe above, everything works as expected. And exiting TakeCommand causes no problems.

I see the same problems if I replace problematic command above with
> tpipe /input=somefile.txt /dup=0,0,1,100,0,0

Is there a problem with tpipe?

rick
 
Jun 6, 2009
19
0
I have attached the relevant options screen shots regarding local versus global history but I think I'm using a global history list.

I am not using a TCEXIT file. Here is my TCSTART.btm file:
-------------------------------
@echo off
::Ignore this file if we are in a pipe or a transient session.
if %_pipe != 0 quit

alias /r "C:\Users\15173\Documents\tcc\alias.ini"

::Do not save the following commands in the history file.
SET HistoryExclude=h;exit;help;history;texdoc;cls;ppath;dir;cd;*cdd

::Shorter prompt `C:\...\current directory'
prompt $w$g
--------------------------------

rick
 

Attachments

Jun 6, 2009
19
0
I was unable to reproduce this behavior on my office machine which has a similar configuration. Would a complete TakeCommand reinstall on my home machine be advisable?

thanks
rick