1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How Are These Normal Directories Being Created Undeletable?

Discussion in 'Open Forum' started by Robin C, Jul 5, 2017.

  1. Robin C

    Joined:
    Jun 24, 2017
    Messages:
    8
    Likes Received:
    0
    This is happening repeatedly using Windows 10 Pro and while at the moment it's only affecting games installations (that I know of) it perturbs me that I don't understand how it's happening.

    Three times now when installing Skyrim from Steam, the directories are created such that they are undeletable and when I try to see their access information in the Security tab of their Properties I get an error telling me I don't have read access to allow me to see this info; and even more oddly a .EXE created dynamically during a Morrowind modification job had the same problem and couldn't be executed, the game didn't come from Steam and none if this installtion's directories had suffered.

    Clearly these file system objects have been created with incorrect ownership but on the face of it they're simply 'userland' processes that are creating them, there's nothing involved that I can see as being a 'system' process which would account for it: I don't see ant DRM reasons why Steam would do this, for example.

    The only way I have found to fix things is to boot to a Recovery Console and use TAKEOWN /F .. /A.

    Can anyone shed some light on what's going on or maybe something I can do within Windows itself using some admin tool I'm not aware of to avoid the need to reboot to recovery to do so?

    Cheers
     
  2. samintz

    samintz Scott Mintz

    Joined:
    May 20, 2008
    Messages:
    1,190
    Likes Received:
    11
    AFAIK, you should still be able to take ownership as an admin. You could also try "PSEXEC /i /s " to run a process as the System user. PsExec is available from SysInternals.com.

    Try something like: psexec /s /i takeown /F .. /A

    -Scott
     
  3. Robin C

    Joined:
    Jun 24, 2017
    Messages:
    8
    Likes Received:
    0
    Thanks for that suggestion Scott but sadly it didn't work on the dynamically created .EXE I mentioned before.

    I ran the Morrowind mod. job which among other things creates a program called NASM.EXE on the fly; I've no idea how it does so but the .EXE certainly doesn't exist before I ran that step:

    From a 'run as admin' TCMD shell on an 'admin' account I get an 'access denied' when trying to run it and when trying to look at the security information I get "You must have Read permissions to view the properties of this object. Click Advanced to continue" and when I click Advanced I get "You do not have permission to view or edit this object's permission settings".

    I tried TAKEOWN but that got the same 'access denied' then tried your PsExec idea:

    \Util\PsTools\psexec /s /i takeown /f "C:\Games\GOG Galaxy\Games\Morrowind\nasm.exe" /a

    PSEXEC exited with a status 1 (a small console window flashed up but too quickly for me to see what it said) and NASM.EXE still gets 'access denied' trying to run/copy it, DIR gives me this:

    c:\games\gog galaxy\games\morrowind >dir nasm.exe
    Directory of C:\Games\GOG Galaxy\Games\Morrowind\nasm.exe
    05/07/2017 17:02 324,608 nasm.exe

    This is beyond annoying, it's clearly a Windows 10 'thing' I've done this several times on multiple Win7 systems over the years and not once has this happened, but this seems infinitely repeatable.
     
  4. samintz

    samintz Scott Mintz

    Joined:
    May 20, 2008
    Messages:
    1,190
    Likes Received:
    11
    You can run TCC.EXE instead of TAKEOWN. That will run TCC as the System user. Then type your Takeown command and the output will show up on the console.
    e.g. \Util\PsTools\psexec /s /i c:\tc21\tcc.exe
     
  5. Robin C

    Joined:
    Jun 24, 2017
    Messages:
    8
    Likes Received:
    0
    Thanks for that good idea Samintz, I hadn't thought of that.
     

Share This Page