How do I get a Git Bash shell to appear in TCC window?

Apr 1, 2016
6
0
I've been banging my head on this one for a few days so thought I would query the collective wisdom. I am trying to get a Git Bash shell to run inside TCC instead of as a separate unattached window. I've tried creating a toolbar button, set to open in a new window, but it just won't come up inside TCC. If I set it to send to the current tab it simply echoes the command to the prompt in the current window. Executing that command opens the bash shell in its own window outside of TCC.

TIA
 

samintz

Scott Mintz
May 20, 2008
1,434
13
Solon, OH, USA
How are you starting it? This is the command I use:
Code:
"C:\Program Files\Git\usr\bin\bash.exe" --login -i

And are you talking about starting it in a tabbed window in TakeCommand or in the same console as TCC?
 
May 20, 2008
10,680
83
Syracuse, NY, USA
How are you starting it? This is the command I use:
Code:
"C:\Program Files\Git\usr\bin\bash.exe" --login -i

And are you talking about starting it in a tabbed window in TakeCommand or in the same console as TCC?
And that works in a TCMD tab.

I don't know what's happening but if I run ...\git\git-bash.exe, I get three new processes ... git-bash.exe, bash.exe, and a new conhost.exe. That doesn't seem to work in a TCMD tab. When I installed Git, I chose "Git from the command line & 3rd party software" and "Use Windows default console". I don't know what would happen if you chose to use the Git console emulator but I'm pretty sure that wouldn't work in a TCMD tab..
 
Apr 1, 2016
6
0
Thanks for the reply. Sorry if I was unclear. I want the bash shell to be in a TCMD tab.

I added your switches and now the bash shell just opens and closes. This is the command I'm using:

"C:\Program Files\Git\git-bash.exe"

I will try using the standard bash shell instead of git-bash.
 
Apr 1, 2016
6
0
No joy. Using the standard bash shell basically starts and disappears. I do have a pile of conhost tasks. To be honest I don't recall what options I selected when I installed Git. I'll try to see if that has any effect. Thanks again for your feedback.
 
Apr 1, 2016
6
0
I restarted my system and now the standard bash shell does come up in a TCMD tab. It does not like the switches, however. If I put them in, it does the disappearing trick. Finally, when the bash shell opens it echoes:

bash: cut: command not found

It doesn't seem to affect anything important. Small steps...

Thanks again.
 
May 20, 2008
10,680
83
Syracuse, NY, USA
bash: cut: command not found
Just a (wild) guess. In ...\Git\usr\bin (or ...\Git\bin if it exists) there may be cut.exe. For it to be found, some Git directories might need to be in your PATH environment variable. That was one of the install options.

I didn't use the switches when I tried Scott's command line.