How to bypass UAC warning when shortcut in \Startup folder ?

May 20, 2008
9,708
67
Syracuse, NY, USA
It's a BAT/BTM file and in %appdata%\Microsoft\Windows\Start Menu\Programs\Startup folder
Then I suppose the BTM does something which requires elevation. Either of these should work.

1. Create a scheduled task ... run with highest privileges ... triggered by logon ... action = [path]\tcc.exe /c [path]\thebatfile.btm ... put thebatfile.btm anywhere (not in startup)

2. Create a task (name=runmybtm) ... highest privileges ... no trigger ... run on demand ... action = [path]\tcc.exe /c [path]\thebatfile.btm ... put thebatfile.btm anywhere (not in startup) ... put a shortcut in Startup which runs: "schtasks.exe /run /tn runmybtm"
 
Jun 2, 2008
317
1
How do you do that ... and doesn't it give a UAC prompt every time TCC is started?
Via the "Run this program as an administrator" option on the Compatibility tab in the properties for tcc.exe itself. Yeah, it definitely would.
 
May 26, 2008
509
4
It's a BAT/BTM file and in %appdata%\Microsoft\Windows\Start Menu\Programs\Startup folder
There isn't a way to suppress the UAC prompt by using the Startup folder.

One workaround is to use Task Scheduler. Create a task that is triggered "At Logon" and configure it to run the task Elevated. This does not produce a UAC prompt.
 
Aug 23, 2010
445
5
@Charles G , I suppose, you've made a mistake once in the past when editing LNK properties.
There's two places, where you can set "run as administrator" checkbox.
One at the "Shortcut" tab, the "Advanced..." button, and another is on the "Compatibility" tab.

THE LATTER ONE CHANGES SETTING IN WINDOWS ITSELF FOR A SPECIFIED EXECUTABLE!
What you really want is the first one.