How to copy an old xp drive to a large ntfs drive

Jul 18, 2009
30
0
I am new to TCC and am using a 30 day evaluation of the latest version.
Formerly I had and used version 12 but it's been a long time.
I'm a Linux user and Windows is hard for me.

The old version 12 is on the drive I want to copy
and I don't know the syntax of a copy command that would copy the entire old xp drive to a subdirectory on my newly installed 1.5 tb ntfs drive.

I tried twice but was unable to create the proper command line.
I ended up with a partially filled directory that I could not figure how to delete.

I basically need to copy Program Files and Users which would give me all my personal data and programs which hopefully will run.

Larry
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,466
88
Albuquerque, NM
prospero.unm.edu
You should be able to copy all files from one location to another with something like this:

Code:
copy /a: /s /k c:\source\* d:\target\

However, don't assume that copying all the files under "Program Files" will give you working software on the target drive. Most software is more than just the files in its install directory; programs will also install .DLLs in the system directory, put information in the registry, configure themselves (and possibly tie themselves to) the specific hardware of the original computer, add environment variables.... The proper way to move software is to install it on the new computer from the original media, if at all possible.
 
May 24, 2010
855
0
Northlake, Il
To add some more to what Charles has said, if the drive you are copying from was drive C: and you are copying to what is now (or will be) drive C: (and you copy from and to the "root" directories on each drive) you might be (at least mostly) OK. However, if you are not for whatever reason(s) you will have to re-install all of the software that no longer works; hopefully you still have and can find the installation media for that software. And it might be better if your "old" drive C: remains your drive C: (and the new drive would therefore be D: or later) until the copy has been completed, after which you physically remove drive C: and reboot making the new drive drive C:. (BTW, if you follow this procedure and what was on the old drive was an earlier (likely) version of Windows then you have (or want) now; you will have to (re-)install Windows after completing the above procedure.)
 
Jul 18, 2009
30
0
Thanks to both Charles Dye and mathewsd w.

The reason I wanted to copy _most_ of the old drive is so I can dig up software I used to use and replace it on the new drive with newer versions
and also to be able to use the old parameters on those programs that had parameters in them. These are all ham radio program files so of course I want to know what files to replace and how to reproduce the settings. The most important file was my ham radio log with about 30,000 records of contacts over 60 years which I just copied as a single file copy from a USB sled.

Which brings me back to my original question.

I need to create a new subdirectory and copy over the important data for my programs and their data and various notes that I have written over the many years of hamming.

But I'm not sure of the proper syntax and, as I stated before, I tried twice to just make a copy of the files to my subdirectory and that did not work.

So my request is:
My request is what is the exact syntax to copy my files from the original drive to my new 1.5 TB drive so I would have a faithful copy to use as a starting point to replace the old programs with newer versions.

My second request is how to I delete the tree of the 2 subdirectories I created that seem grossly incomplete with only 2 files in each
that I cannot seem to delete. Where ever did good old deltree go?

BTW, I have been using JPSoft sortware for many years starting with 4dos and then 4nt and purchased new versions over the years.
One of the things I hope to be able to reproduce is my extensive alias files mostly constructed by myself.

Now I use Linux and I'm happy to say that the JPSoftware is very similar to bash which I use all the time (except for syntax).

Please forgive my ignorance of Windows CLI usage but it's been many years since I used Windows much.
I'd be grateful for any help you can give me.

Larry
 
May 24, 2010
855
0
Northlake, Il
Larry, it seems to me that if these are old ham-radio programs it is unlikely that they are "Windows GUI" programs but, rather, are strictly command-line programs. If that is in fact the case, then Charles's instructions are completely relevant pretty much without modification (although be careful about the exact syntax) because "registry" and "DLL" issues generally won't exist (any needed DLL's, if there even are any which is probably most likely the not the case for command line programs) would most likely be contained in the same directory that contains the program itself. For those programs that are Windows GUI programs, it's worthwhile to test them before proceeding but there is a good possibility that what Charles suggest applies in which case you'll either have to re-install them or do what I suggested (which is only really a good solution if you've got a lot of these programs or you no longer have the installation files for the ones that you consider "important" and aren't able to (re-)acquire them). But it seems likely to me that the first situation is really the case here.

- Dan
 
May 20, 2008
3,515
4
Elkridge, MD, USA
My request is what is the exact syntax to copy my files from the original drive to my new 1.5 TB drive so I would have a faithful copy to use as a starting point to replace the old
programs with newer versions.
The alias below is what I use all the time:

alias fullcopy=*copy/[!descript.ion]/e/f/g/r/h/v/netj/j

The command below should do the job for you:

fullcopy /s source target

My second request is how to I delete the tree of the 2 subdirectories I created that seem grossly incomplete with only 2 files in each that I cannot seem to delete. Where ever did good old deltree go?
The aliases below are what I use all the time. USE WITH CAUTION! TEST FIRST!

alias era*se=*del/q/y/z/nejt
"era file" deletes without confirmation prompting all files in the current directory, EXCEPT files which have been opened and not closed, that match the name "file", which can contain wildcards. If "file" is * (asterisk), deletes all files.

alias exs=era/x/s
"exs file" deletes all instances of "file" in the current directory AND ALL ITS SUBDIRECTORIES, and deletes any subdirectory that is left empty. Use * as filename, or name one of the subdirectories, and it does "deltree"
.
alias noempties=*del/q/y/x/s/net/a:d .
Prunes the current directory and its subdirectories so there are no branches without files.
 
Which operating system are you running Take Command under Larry?? It sounds to me like you are falling foul of file permission and/or UAC elevation issues, both more than possible under either Vista or Win7. Take Command does not run in Admin mode by default so you may need to start an elevated TCC to achieve what you're after (see the /ELEVATED switch on the START command) - FWIW I have an alias:

ele*vate=*start /elevated

whereby I can start an elevated TCC by simplying issuing an elevate command or do things like:

elev secpol.msc

to start MMCs in admin mode.
 
Similar threads
Thread starter Title Forum Replies Date
M “Reawakeng" of an old issue with the "copy" command that I'm not sure I've ever reported in the past Support 6
C Copy (sys) error Support 3
Alpengreis Fixed Crash after copy dialog with big TCC.exception.log Support 5
vefatica Copy/Paste anomaly Support 4
D Documentation Typo in COPY help Support 0
samintz COPY fails to copy from \\wsl$ Support 20
D Differences between TCC and CMD with COPY /b Support 4
fpefpe copy /u and timestamps Support 4
M Strange error messages from TCC in FTP copy Support 7
G TCMD crash when copy Support 3
Alpengreis How to? Copy DIRs with attributes ... Support 4
E Text copy bug Support 1
Alpengreis [TCMD v25.00.24] Problem with copy and paste and the # char via mouse in TCC Support 6
fpefpe copy/cat Support 7
K copy /w slow relative to robocopy /mir Support 0
Jay Sage Problem with Context Menu Copy+Paste+Run Key Assignment Support 7
K "copy /z /w" command not deleting read-only files in destination Support 10
K copy changing destination current directory Support 1
D Keystroke to copy previous argument Support 3
A How to? Copy+Paste in TCMD tabs with Ctrl-Shift-Ins? Support 5
RChrismon How to? Copy TCMD.INI to New Version Support 7
R How to? Append files in multiple subfolders using copy? Support 8
Dick Johnson COPY /u (?) Support 9
fpefpe Documentation copy /u Support 7
R How to? copy /q ABC.txt + DEF.txt is appending hex 1A Support 8
D copy /g only shows transfer rate Support 1
J Error "Contents lost before copy" Support 3
B Can copy command concatenate multiple mp3 files Support 2
rps Documentation "Copy+Paste+run" question Support 2
kb6ojs Make /G parameter persistent in COPY/MOVE command? Support 4
fpefpe How to? copy / exclude Support 2
fpefpe robocopy -- copy /w Support 8
C copy /w /p prompts for deletion, but ... Support 3
D Fixed Copy Support 1
fpefpe Documentation copy/move using /c or /u Support 2
samintz WAD Copy/append adds a character Support 3
P Simple RegEx copy Support 9
fromano Fixed COPY ... TO ... crashing Support 3
Alpengreis How to? Copy & Paste without linebreak within TCMD Support 13
D COPY returns ERRORLEVEL 2 Support 5
mdwyer TCC 13 COPY: specified network name is no longer available. Support 5
CWBillow Copy a tree Support 17
J junction copy/move handling Support 6
vefatica Fixed COPY /S ftp://... Support 1
C WAD copy /u ftp local with Timeout? Support 5
D How to? Unregister a copy of Take command Support 1
vefatica FTP copy interrupted Support 2
C How to? COPY ftp folder query Support 7
R How to? TCC 16.03: copy a file to the clipboard? Support 10
jadaml Documentation Is COPY realy doesn't work for any HTTP and FTP? Support 3

Similar threads