IDE v10 questions

1. In an earlier thread, Rex mentioned something about changing shortcut
keys in the IDE via a Customize menu. I have not been able to find this
option. Where should I be looking?

2. In the IDE's View menu, going to the first item, Toolbar, and pressing
enter doesn't seem to have any effect. Unlike other items in the menu,
there is no checkbox next to it. Or perhaps there is but my screen reader,
JAWS 10.0, isn't seeing it for some reason.

3. JAWS has a function that can automatically label toolbar buttons. It
does this by moving the cursor to each graphic and labeling it with tool tip
text. For some reason this does not work for the IDE. Rex, I know you're
not a screen reader expert, but I'm wondering if the IDE is presenting its
tool tips in some way that JAWS can't handle.

--
Howard
 

rconn

Administrator
Staff member
May 14, 2008
12,404
152
Howard Goldstein wrote:

> 1. In an earlier thread, Rex mentioned something about changing shortcut
> keys in the IDE via a Customize menu. I have not been able to find this
> option. Where should I be looking?

Right click on the menu, select "Customize", then "Keyboard".


> 2. In the IDE's View menu, going to the first item, Toolbar, and pressing
> enter doesn't seem to have any effect. Unlike other items in the menu,
> there is no checkbox next to it. Or perhaps there is but my screen reader,
> JAWS 10.0, isn't seeing it for some reason.

Are you setting MSAAMenu in TCMD.INI?


> 3. JAWS has a function that can automatically label toolbar buttons. It
> does this by moving the cursor to each graphic and labeling it with tool tip
> text. For some reason this does not work for the IDE. Rex, I know you're
> not a screen reader expert, but I'm wondering if the IDE is presenting its
> tool tips in some way that JAWS can't handle.

I have no idea. Does it work with the Take Command toolbars?

Rex Conn
JP Software
 
> ---Quote---
>> 2. In the IDE's View menu, going to the first item, Toolbar, and
>> pressing
>> enter doesn't seem to have any effect. Unlike other items in the menu,
>> there is no checkbox next to it. Or perhaps there is but my screen
>> reader,
>> JAWS 10.0, isn't seeing it for some reason.
> ---End Quote---
> Are you setting MSAAMenu in TCMD.INI?
>
Yes. And now I see that I have the same problem with the Toolbar item in
TCMD's menu. (This is still build 38; I haven't had a chance to try
anything later.)

>
>
> ---Quote---
>> 3. JAWS has a function that can automatically label toolbar buttons. It
>> does this by moving the cursor to each graphic and labeling it with tool
>> tip
>> text. For some reason this does not work for the IDE. Rex, I know
>> you're
>> not a screen reader expert, but I'm wondering if the IDE is presenting
>> its
>> tool tips in some way that JAWS can't handle.
> ---End Quote---
> I have no idea. Does it work with the Take Command toolbars?
>
I can't really tell because the Take Command toolbar already has text
labels.

--
Howard
 
Similar threads
Thread starter Title Forum Replies Date
Peter Bratton v10 IDE / bdebugger Support 10
old coot Is there a consistent way to do a single-key repeat search in the edit/debug IDE? Support 5
Kachupp IDE watch references Support 11
T Thanks for the assistance with IDE vs Bdebugger Support 3
vefatica IDE external command syntax color? Support 1
K_Meinhard Small problem in german IDE 26 Support 3
vefatica IDE - when breakpoint is on a blank line? Support 3
Peter Murschall IDE: After undocking the command expansion Window is offended Support 2
Peter Murschall IDE: Ctrl-W is a Harakiri Command ! Support 23
Kachupp ide/bdebugger Support 17
rps IDE/BDEBUGGER ? Support 1
vefatica IDE.EXE's command line? Support 19
Peter Murschall IDE: RTL with non-English resources-problem is back in Build 28 Support 4
Peter Murschall v24 IDE/BDEBUGGER won't start Support 9
vefatica IDE stuck on "Insert tabs as spaces" Support 0
Peter Murschall IDE/BDEBUUGER in TCC 22 didn't run Support 7
T Fixed Problem with use of Batch parameters in the IDE Support 1
T Fixed IDE locks up if edit window for running batch is closed Support 6
Peter Murschall IDE destroys Text on Ctrl-U/Ctrl-Shift-U Support 12
C BDEBUGGER/IDE crashing Support 1
vefatica Monospace font in IDE? Support 3
vefatica IDE crashes every time Support 6
R TCC IDE Tabs - inactive tabs hard to see Support 14
vefatica IDE crashing Support 11
vefatica Why doesn't "IDE %_ININAME" work? Support 4
vefatica IDE's dynamic help ... Support 0
vefatica Contuing IDE gripes Support 11
vefatica WAD IDE, output window to foreground Support 3
vefatica Fixed IDE weirdness Support 3
vefatica IDE double-click select? Support 29
vefatica Doesn't IDE auto-indent? Support 3
T bdebugger / ide usage confusion Support 14
vefatica Fixed Font corruption in IDE Support 3
vefatica IDE status bar row/column? Support 0
vefatica An IDE anomaly Support 2
T Associating BTM files with IDE results in DOS box Support 33
S WAD IDE /C does not accept truename of future file Support 13
S How to? Is it possible for the IDE to start without plugins? Support 3
S Documentation "HELP IDE" - missing reference Support 0
Mordachai Fixed Closing TCMD while IDE + Help Open = Crash Support 7
jwiede ide.exe not launching? Support 13
F No ide.exe or tcmd.exe files - Win7 64bit Support 5
T Syntax highlighting in the IDE Support 8
Frank watch an array variable in ide/bdebugger Support 2
Peter Murschall Is IDE forbidden in TCSTART.BTM ? Support 4
rfaquino TCMD 14.0 IDE Crash Support 7
epement differences in IDE/debugger between v12 and v14 Support 1
Alan Strader Take Command IDE/Debugger has stopped working Support 5
J Fixed IDE search keys don't work in TCMD 13.01.32 Support 3
vefatica IDE watch window Support 1

Similar threads