ift upgrade problem

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Sep 24, 2008
23
0
#1
I'm setting up a new workstation and installed the newest version of TCC. But my btm files no longer work correctly.

Old system:
xpPro workstation
Take Command (suite) 8.01.69
btm files with iftp commands targeting a remote Windows 2003 server

New system:
Windows Server 2008 used as a workstation
Take Command 9 downloaded a couple of days ago



I have copied the btm files to the ServerAsWorkstation, and have tried to
run them.

I had to manually associate the btm extension with TCC.exe. (could not
associate with 4nt.exe)

When I run the scripts, the target server is contacted, and folders are
created on the target server, but files are created as zero-length files,
and an error is reported in the script window for each copy attempt:

"425 Can't open data connection"

There is considerable time taken for each file copy attempt and its
related error message.


Do need to modify my scripts to run with the newest TCC version?
 
#2
JP Software Forums" <neil@jpsoft.com>; "Kygre wrote:
| I'm setting up a new workstation and installed the newest version of
| TCC. But my btm files no longer work correctly.
|
| Old system:
| xpPro workstation
| Take Command (suite) 8.01.69
| btm files with iftp commands targeting a remote Windows 2003 server
|
| New system:
| Windows Server 2008 used as a workstation
| Take Command 9 downloaded a couple of days ago
|
|
|
| I have copied the btm files to the ServerAsWorkstation, and have
| tried to
| run them.
|
| I had to manually associate the btm extension with TCC.exe. (could not
| associate with 4nt.exe)

There is a batch file in the distribution to do that: tccbatch.btm ...

| When I run the scripts, the target server is contacted, and folders
| are
| created on the target server, but files are created as zero-length
| files,
| and an error is reported in the script window for each copy attempt:
|
| "425 Can't open data connection"
|
| There is considerable time taken for each file copy attempt and its
| related error message.
|
|
| Do need to modify my scripts to run with the newest TCC version?

I suspect the problem is one of permission to actually write the file bodies
to the target drive. You may need to run TCC with more privileges. However,
I have not run on anything newer than WinXP.

The delays are normal - when a write attempt fails, it is usually attempted
again.
--
Steve
 
Sep 24, 2008
23
0
#3
Steve,

Thanks for the info.

Regarding permissions, I am logged in as Administrator on the 2008 server-workstation, and I installed TCC as Administrator. Still it seems possible.

On the other hand, the folders get created, and zero-length files are created... seems like that would include copy privileges...

Kygre


JP Software Forums" <neil@jpsoft.com>; "Kygre wrote:
| I'm setting up a new workstation and installed the newest version of
| TCC. But my btm files no longer work correctly.
|
| Old system:
| xpPro workstation
| Take Command (suite) 8.01.69
| btm files with iftp commands targeting a remote Windows 2003 server
|
| New system:
| Windows Server 2008 used as a workstation
| Take Command 9 downloaded a couple of days ago
|
|
|
| I have copied the btm files to the ServerAsWorkstation, and have
| tried to
| run them.
|
| I had to manually associate the btm extension with TCC.exe. (could not
| associate with 4nt.exe)

There is a batch file in the distribution to do that: tccbatch.btm ...

| When I run the scripts, the target server is contacted, and folders
| are
| created on the target server, but files are created as zero-length
| files,
| and an error is reported in the script window for each copy attempt:
|
| "425 Can't open data connection"
|
| There is considerable time taken for each file copy attempt and its
| related error message.
|
|
| Do need to modify my scripts to run with the newest TCC version?

I suspect the problem is one of permission to actually write the file bodies
to the target drive. You may need to run TCC with more privileges. However,
I have not run on anything newer than WinXP.

The delays are normal - when a write attempt fails, it is usually attempted
again.
--
Steve
 
Sep 24, 2008
23
0
#4
In case I was doing something wrong previously (even though it worked in TCC 8) I'm adding a sample of the scripts that won't run correctly on newest TCC version. Note that folders and zero length files get created on the target.


set SrcFullPath=%SrcDrive%%SrcPath%%SrcFolder%
set Target=ftp://%Lgn%:%Pwd%@%TrgIp%%TrgPath%%TrgFolder%/
iftp %Target%
set Target=ftp:
copy /U %SrcFullPath%\AppSettings%TrgMachine%.config %Target%
copy /U %SrcFullPath%\DbConnect%TrgMachine%.config %Target%
iftp /c

set SrcFullPath=%SrcDrive%%SrcPath%%SrcFolder%\Bin
set Target=ftp://%Lgn%:%Pwd%@%TrgIp%%TrgPath%%TrgFolder%/
iftp %Target%
set Target=ftp:Bin
copy /U /S %SrcFullPath%\*.dll %Target%
dir "ftp:Bin\*.*"



I'm setting up a new workstation and installed the newest version of TCC. But my btm files no longer work correctly.

Old system:
xpPro workstation
Take Command (suite) 8.01.69
btm files with iftp commands targeting a remote Windows 2003 server

New system:
Windows Server 2008 used as a workstation
Take Command 9 downloaded a couple of days ago



I have copied the btm files to the ServerAsWorkstation, and have tried to
run them.

I had to manually associate the btm extension with TCC.exe. (could not
associate with 4nt.exe)

When I run the scripts, the target server is contacted, and folders are
created on the target server, but files are created as zero-length files,
and an error is reported in the script window for each copy attempt:

"425 Can't open data connection"

There is considerable time taken for each file copy attempt and its
related error message.


Do need to modify my scripts to run with the newest TCC version?
 
May 30, 2008
42
0
#5
From: JP Software Forums
Sent: Thursday, September 25, 2008 12:27 PM
Subject: RE: [Support-t-498] Re: ift upgrade problem
[snip]

> "425 Can't open data connection"
>
> There is considerable time taken for each file copy attempt and its
> related error message.
I have to say, the symptoms look remarkably like having a firewall
discarding the connection request that the server makes back to the client
for the file transfer. Are the two machines plugged into the same network
with exactly the same configuration? Is the original machine acting as a
"DMZ" on a NATted LAN? Double-check that the Windows Server 2008 machine
does not have its firewall on, or if it does and you want it on, that it is
making an exception for the FTP connections you need.

Jonathan Gilbert
 
Sep 24, 2008
23
0
#6
Yes it could be the serverworkstation firewall. I've just looked at Windows Firewall on Server 2008, and can't figure out exactly what to do.

I can add TCC.exe, but there are a lot of options in the wizard that I have know idea how to set. The firewall on server is way more involved than on Vista.

Does anyone have a suggestion?

Thanks,

Kyle



From: JP Software Forums
Sent: Thursday, September 25, 2008 12:27 PM
Subject: RE: [Support-t-498] Re: ift upgrade problem
[snip]



I have to say, the symptoms look remarkably like having a firewall
discarding the connection request that the server makes back to the client
for the file transfer. Are the two machines plugged into the same network
with exactly the same configuration? Is the original machine acting as a
"DMZ" on a NATted LAN? Double-check that the Windows Server 2008 machine
does not have its firewall on, or if it does and you want it on, that it is
making an exception for the FTP connections you need.

Jonathan Gilbert
 
Sep 24, 2008
23
0
#7
The problem may be solved. I tried adding 4nt.exe to the inbound rules and the script started working. Adding tcc.exe was not enough.

I'll have to do a few more tests to be sure, but it looks ok now.

Thanks,

Kyle