iftp problem

D

drrob1

Guest
Win XP SP3
tcmd 12.11.72

iftp ftp://site1
copy file1 ftp:
iftp /c

iftp sftp://site2
copy file1 ftp:
iftp /c

Now if I use FileZilla to see what's up, I find that site 2 does not have a copy of file1; both iftp sessions sent file1 to site 1

Is my syntax incorrect, or have I uncovered a bug?

--rob solomon
 

rconn

Administrator
Staff member
May 14, 2008
12,345
150
> iftp ftp://site1
> copy file1 ftp:
> iftp /c
>
> iftp sftp://site2
> copy file1 ftp:
> iftp /c
>
> Now if I use FileZilla to see what's up, I find that site 2 does not have
a copy

> of file1; both iftp sessions sent file1 to site 1
>
> Is my syntax incorrect, or have I uncovered a bug?

The former -- you opened an FTP and an SFTP site, but only copied to the FTP
site. Your second copy should be:

Copy file1 sftp:

Otherwise IFTP is assuming you wanted to reopen site1 and copy the file
there again.

Rex Conn
JP Software
 
Jan 24, 2009
36
0
That's working. Thanks.

Sent from my Verizon Wireless 4GLTE smartphone

----- Reply message -----
From: "rconn" <>
To: <rob@drrob1.com>
Subject: [Support-t-3012] iftp problem
Date: Fri, Jul 29, 2011 12:46 am


---Quote---

> iftp ftp://site1
> copy file1 ftp:
> iftp /c
>
> iftp sftp://site2
> copy file1 ftp:
> iftp /c
>
> Now if I use FileZilla to see what's up, I find that site 2 does not have
---End Quote---
a copy


---Quote---

> of file1; both iftp sessions sent file1 to site 1
>
> Is my syntax incorrect, or have I uncovered a bug?
---End Quote---
The former -- you opened an FTP and an SFTP site, but only copied to the FTP
site. Your second copy should be:

Copy file1 sftp:

Otherwise IFTP is assuming you wanted to reopen site1 and copy the file
there again.

Rex Conn
JP Software
 
Similar threads
Thread starter Title Forum Replies Date
vefatica WAD IFTP - old problem still there Support 2
cgunhouse Problems With IFTP Support 3
vefatica IFTP and SFTP Support 7
vefatica WAD IFTP timeout? Support 3
B when doing SFTP via IFTP to my secure site my users always get the finger print key prompt Support 1
S iftp copying pgp files from ftp is not working Support 11
cgunhouse IFTP "/S" Option Support 6
cgunhouse IFTP Path Issue in V17 - Fixed Support 7
vefatica IFTP and active FTP Support 13
vefatica Both IFTP problems remain in build 50 Support 35
vefatica More on IFTP Support 7
vefatica IFTP problems (broken pipe?) Support 24
cgunhouse Foldermonitor and iftp Support 1
Charles Dye Minor nit: DIR /F, IFTP, colorization Support 4
Charles Dye IFTP, current directory, open new connection Support 0
D iftp failure after upgrading to build 65 Support 9
S FTP site; IFTP access Support 10
K iftp script copy deletes target files Support 17
J Problems with FTP after IFTP timeout Support 2
P iftp with ftp proxy Support 0
J IFTP issue Support 1
nikbackm IFTP questions Support 3
D "534 Fallback to [C]" after iftp Support 7
Dick Johnson Weird Color Problem Support 8
fishman@panix.com Problem with 27.15 Support 2
M Problem with VSDevCmd.bat in VS 16.7.3 Support 0
R Problem with @INT[ value] in V26 Support 9
M Selecting test "off by one" problem in Take command Support 4
Alpengreis UTF-8 problem in TCC related to Python Support 7
K_Meinhard Small problem in german IDE 26 Support 3
B Problem with color in nested shells Support 1
Joe Caverly Problem creating and switching to a DESKTOP Support 9
vefatica Another popup problem Support 10
Alpengreis ffind dialog (/W) problem Support 4
Alpengreis [TCMD v25.00.24] Small space problem with the DE translation in Prefs-GUI Support 1
Alpengreis [TCMD v25.00.24] Problem with copy and paste and the # char via mouse in TCC Support 6
A Problem with functions @int @decimal and identifying Powershell as a shell. Support 12
B IF command problem in tcexit.btm Support 9
fishman@panix.com Problem at Startup of TCC Support 3
P Problem with SFTP copies Support 7
P Problem with FTP copies Support 10
Jay Sage Problem with Context Menu Copy+Paste+Run Key Assignment Support 7
R Problem with %_do_loop in nested do loops Support 2
fishman@panix.com New Problem with later Windows 10 Support 10
Peter Murschall A little problem with LEAVE and COMMENT Support 5
M Handling of %~I problem Support 4
WinLanEm FOR problem Support 18
K Problem With SCRPUT /u Support 3
vefatica What's TCMD's problem with ^e[0m? Support 13
Peter Murschall IDE: RTL with non-English resources-problem is back in Build 28 Support 4

Similar threads