Implementing directives via file-manager

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Jul 15, 2010
6
0
#1
I'm using TC Version 11.0 on Windows XP, SP2. I’m familiar with 4DOS, but not Take Command.

When I double-click a btm file from my file-manager (NOT in the TC Console), and the btm is something simple (maybe just "pause"), the tcc.exe window opens with the "Copyright" header displayed.

Is there a way to have the "Copyright" header not be displayed when I click a btm from my file-manager?

I know about the /Q directive. I made a TC SHORTCUT to tcc.exe and when I click on it from my file-manager, the tcc.exe window opens without the header. So, the shortcut works.

But, in order for that to happen when I click on a btm file from my file-manager, I need to Associate btm files with the shortcut. But, my XP Control Panel >> Folder Options >> File Types doesn't show the link when I browse to its directory.

This header issue is insignificant and inconsequential, but this seems like a reasonable expectation of directives as I understand them, and there may be other directives I’ll want to use in the future.

Regards.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,385
39
Albuquerque, NM
prospero.unm.edu
#2
I'm using TC Version 11.0 on Windows XP, SP2. I’m familiar with 4DOS, but not Take Command.

When I double-click a btm file from my file-manager (NOT in the TC Console), and the btm is something simple (maybe just "pause"), the tcc.exe window opens with the "Copyright" header displayed.

Is there a way to have the "Copyright" header not be displayed when I click a btm from my file-manager?

I know about the /Q directive. I made a TC SHORTCUT to tcc.exe and when I click on it from my file-manager, the tcc.exe window opens without the header. So, the shortcut works.

But, in order for that to happen when I click on a btm file from my file-manager, I need to Associate btm files with the shortcut. But, my XP Control Panel >> Folder Options >> File Types doesn't show the link when I browse to its directory.

This header issue is insignificant and inconsequential, but this seems like a reasonable expectation of directives as I understand them, and there may be other directives I’ll want to use in the future.
You don't want to associate .BTM files with a shortcut; you want to associate them with TCC.EXE, including whatever switches are appropriate. You can do this using the ASSOC and FTYPE commands.

Start by typing
Code:
assoc .btm
to find Windows's symbolic name for this filetype. In my case it's "btmfile", but on your system it's probably different.

Then you can use FTYPE to associate that file type with the executable. I haven't tested, but it would probably look something like this:

Code:
ftype btmfile=`c:\bin\tcmd\tcc.exe /q /c "%1" %*`
Note the use of backquotes to protect the percent signs. Replace "btmfile" with whatever ASSOC .BTM reported, and replace the "c:\bin\tcmd\tcc.exe" with the correct path to TCC.EXE on your system -- in double quotes if needed.
 
Jul 15, 2010
6
0
#3
Your instructions for the 'assoc' and 'ftype' did the trick. I had to undo
the association I'd made in the Control Panel, but then it worked fine. That
also showed me how to implement the other 'TCC Startup Options' relative to
the other Startup "options" which I will tackle another day.

Thanks

-----Original Message-----
From: Charles Dye [mailto:]
Sent: Monday, July 19, 2010 7:30 PM
To: mcgraw01@comcast.net
Subject: RE: [Support-t-2173] Re: Implementing directives via file-manager

---Quote (Originally by old4doser)---
I'm using TC Version 11.0 on Windows XP, SP2. I'm familiar with 4DOS, but
not Take Command.

When I double-click a btm file from my file-manager (NOT in the TC Console),
and the btm is something simple (maybe just "pause"), the tcc.exe window
opens with the "Copyright" header displayed.

Is there a way to have the "Copyright" header not be displayed when I click
a btm from my file-manager?

I know about the /Q directive. I made a TC SHORTCUT to tcc.exe and when I
click on it from my file-manager, the tcc.exe window opens without the
header. So, the shortcut works.

But, in order for that to happen when I click on a btm file from my
file-manager, I need to Associate btm files with the shortcut. But, my XP
Control Panel >> Folder Options >> File Types doesn't show the link when I
browse to its directory.

This header issue is insignificant and inconsequential, but this seems like
a reasonable expectation of directives as I understand them, and there may
be other directives I'll want to use in the future.
---End Quote---
You don't want to associate .BTM files with a shortcut; you want to
associate them with TCC.EXE, including whatever switches are appropriate.
You can do this using the ASSOC and FTYPE commands.

Start by typing
Code:
---------
assoc .btm
---------
to find Windows's symbolic name for this filetype. In my case it's
"btmfile", but on your system it's probably different.

Then you can use FTYPE to associate that file type with the executable. I
haven't tested, but it would probably look something like this:


Code:
---------
ftype btmfile=`c:\bin\tcmd\tcc.exe /q /c "%1" %*`
---------
Note the use of backquotes to protect the percent signs. Replace "btmfile"
with whatever ASSOC .BTM reported, and replace the "c:\bin\tcmd\tcc.exe"
with the correct path to TCC.EXE on your system -- in double quotes if
needed.