Incorrect display under TCMD 13

Sep 27, 2009
8
0
Hi,

I find TCMD does not display well on my Win 7 x64 since 11.0 and I have reported before. I download the latest version 13.00.21 x64 but same problem again.

I attached the screen capture for your info. You can see the TCMD think there are 106 columns but actually around 107 columns (by counting on the JPG).

If the tab is detached, the display is good. So the problem occurs only under TCMD.

I think this might be due to Console code page. Below is my PC configuration:
Windows 7 Ultimate SP1 (6.1.7601) x64
System Locale = HKSARG (i.e. Hong Kong)
Console Code page = 950

When I switch to 437 by CHCP, the display is good.




Best Regards,
Ninja
 

Attachments

  • TCMD13_Problem.jpg
    TCMD13_Problem.jpg
    78.9 KB · Views: 86

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,446
88
Albuquerque, NM
prospero.unm.edu
If you detach the tab with the garbled display, does it still look garbled?

Does the problem still occur if you set the tab width to some nice multiple of twenty -- say, 80 or 100 columns?
 
Similar threads
Thread starter Title Forum Replies Date
Charles Dye REGDIR /T : incorrect localization of time stamps Support 4
S incorrect message at start Cancel batch job 4START.bat ? (Y/N/A) : Support 1
rps Fixed @filesize[...,a] space allocated values incorrect Support 2
M TCC incorrect dir output since Windows 1803 Support 6
Fross @Words Incorrect? Support 19
Steve Pitts WAD @MD5 returns incorrect results for strings Support 2
Phil Kane WAD v 17 Displays Incorrect OS Support 6
rps Documentation "Select" command switch order incorrect Support 4
R Fixed Bytes Allocated Total Incorrect in V17 b52 Support 1
M Incorrect ARGV1 when using linux-style paths Support 4
D Minor problem. Incorrect value internal var _dir_files Support 7
S WAD Incorrect _do_loop values Support 18
The Wizard WAD Possible Incorrect COMSPEC handling Support 2
Dan Glynhampton Documentation v15 help: Incorrect Links Support 0
JohnQSmith WAD Incorrect results from @FILESIZE Support 9
T @ping: response code, data size and documentation incorrect Support 2
dcantor @AGEDATE example incorrect in help Support 0
T Incorrect file associations Support 8
C TC10 LIST - print with line nbrs incorrect Support 0
D D:\Settings\Application contains an incorrect path? Support 0
G v28 Display Issue Support 7
samintz WAD Display wrapping issue Support 5
K Fixed Prompt display will be shifted after use dir to display a filename with Chinese. (v25.00.28 x64) Support 18
Jesse Heines How to? How to display picture creation date with dir command Support 6
B Fullwidth Unicode forms display incorrectly Support 5
D Need to set Take Command font size when switching to high DPI display Support 0
T FFind - can we display n number of lines after the find? Support 2
Joe Caverly PSHELL Blank Line Display Support 2
Alpengreis The TCMD Display problems and font size ... Support 2
vefatica Display of special characters in aliases. Support 25
R How to? Display text same as in CMD Support 14
T TCC display issue Support 1
MikeBaas How to? SELECT: exclude files / display prompt Support 2
D WAD TASKBAR options LogOff and ShutDown do not display a dialog Support 2
rfaquino How to? Display filename being copied on a single line Support 2
rps How to? Portable TCMD display problem Support 2
L Windows 8.1 version display Support 5
mfarah How to? Getting pdir to display relative paths. Support 2
D Folders pane display problem when starting Support 4
D Folders pane display problem after rename Support 0
C How to? Multi-Display Configuration Support 5
A WAD Limitations on display of unicode punctuation marks Support 11
Joe Caverly Display the VIEW window in a Take Command tab window Support 2
L FFIND no result display Support 10
B TCC v12 display double problem Support 2
B Bdebugger / IDE editor doesn't display called batch file Support 1
nikbackm UTF-8 display in TCMD Support 1
Peter Bratton IDE environment window display Support 0
G Display setting for Tabbed Toolbar Support 1
MickeyF Nice alias display Support 0

Similar threads