Invisible Output

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Jan 14, 2012
5
0
#1
Since a few weeks, my TCC LE 13.06.77 Windows 7 [Version 6.1.7600] do not displayed all output in a propper way!

e.g. If I start a console, and type "DIR", normaly every thing seems OK, but if I type DIR a second time, only the header and the footer and few of the directories are dispayed, but no files.

A redirection of the command shows the compete output but on screen the color has changed to BLACK on BLACK!!

Any Idees?
 

rconn

Administrator
Staff member
May 14, 2008
10,291
90
#5
Since a few weeks, my TCC LE 13.06.77 Windows 7 [Version 6.1.7600] do not displayed all output in a propper way!

e.g. If I start a console, and type "DIR", normaly every thing seems OK, but if I type DIR a second time, only the header and the footer and few of the directories are dispayed, but no files.

A redirection of the command shows the compete output but on screen the color has changed to BLACK on BLACK!!
This cannot be a TCC/LE bug. TCC/LE doesn't have anything to do with how text is displayed in a console window; that's done by Windows (specifically conhost.exe). TCC/LE just makes Windows API calls to output text.

The only thing that could be TCC/LE related is if you have defined DIRCOLORS and you've got an extension defined that is resulting in a black on black display. (Or less likely that you have ANSI output enabled and you're displaying filenames and/or file descriptions that have embedded ANSI sequences.)