Keys and IDX not working

Sep 30, 2016
7
0
#1
Hi,

I'm using TCCv20. I'm running Windows 10 in a VM (Parallels). Unfortunately it seems that some essential keys and the IDX file do not work in TCC. I have created a jpstree.idx file for all drives (it is in there and about 12 MB). Strangely after that when on C:\ and putting the incomplete command "cdd JPS" I expected that TCC would find the diretory "JPSoft". But I got an error message that it could not find the path. After inputing commands I cannot recall these via up and down keys (in the history log file everything is there). And PageDown and PageUp do not pop up a directory listing so I can select a line.

How can I fix that? Or: how can I assign different keys for these keys?

Best regards,
Ulrich
 

rconn

Administrator
Staff member
May 14, 2008
10,533
94
#2
First, check your OPTION dialog to see if:

1) You have "Everything Search" enabled on the "Startup" page (if so, you need to have Everything Search loaded & it will ignore your jpstree.idx file).
2) You have "Extended Directory Search" enabled (1, 2, or 3) on the "Command Line" page, and the path to your jpstree.idx file set if you put jpstree.idx in a non-default location.

I cannot reproduce a problem with the history recall keys (if there were a problem there, there'd be a few thousand bug reports!).
 
Sep 30, 2016
7
0
#3
ad 1) yes, it seems to be enabled (startup tab, last entry on the right side)
ad 2) yes, Extended Directory Search is enabled with 3 and path is set to h:\ (which is \\Mac\Home actually, and there is the idx file and the log file)
And now?
 
#3
First, would the IDX be current and up to date? CDD /S to recreate the index

Do you have Everything turned off? OPTION, Startup tab, lower right [ ] Everything Search.....

Then not sure how this would effect your problem - but OPTION, Command Line tab, Extended Directory Search has Search Level and Path. what are these set to?
 

rconn

Administrator
Staff member
May 14, 2008
10,533
94
#4
ad 1) yes, it seems to be enabled (startup tab, last entry on the right side)
ad 2) yes, Extended Directory Search is enabled with 3 and path is set to h:\ (which is \\Mac\Home actually, and there is the idx file and the log file)
And now?
If "Everything Search" is enabled, then TCC won't use jpstree.idx, it will use the ES database. You either need to turn off that option, or make sure that ES is running and has created its database.

ES is the preferred approach now for fuzzy directory searches, as it is much, much faster than using jpstree.idx. (TCC still supports jpstree.idx for backwards compatibility.)
 
Sep 30, 2016
7
0
#5
Ok. When disabling "Everything Search" the command "cdd JPS" pops up the window as expected. So you wrote that "Everything Search" is the better choice. Then I have to put "0" to the "Extended Diretory Search", yes? And how to include in "Everything Search" all my network drives?

And my last question: the up and down arrow keys don't work on the command line as to go back and forth in the history. Can I reassign the keys to something else and how exactly?
 

rconn

Administrator
Staff member
May 14, 2008
10,533
94
#6
And my last question: the up and down arrow keys don't work on the command line as to go back and forth in the history. Can I reassign the keys to something else and how exactly?
You *could* remap your keys (see "Key mapping directives" in the help), but I think the better approach would be to figure out why Parallels isn't passing the cursor keys to TCC.
 

rconn

Administrator
Staff member
May 14, 2008
10,533
94
#7
Ok. When disabling "Everything Search" the command "cdd JPS" pops up the window as expected. So you wrote that "Everything Search" is the better choice. Then I have to put "0" to the "Extended Diretory Search", yes? And how to include in "Everything Search" all my network drives?
First, you need to select Everything Search during the installation.

Then, run "everything /o" from the TCC prompt, select "Tools / Options", click on "Indexes / NTFS", and select the drives you want to include in the ES database.
 
Sep 30, 2016
7
0
#8
You *could* remap your keys (see "Key mapping directives" in the help), but I think the better approach would be to figure out why Parallels isn't passing the cursor keys to TCC.
Yes, I have already contacted Parallels support. It's very strange since TCC is the only program where cursor keys didn't work!
 
Sep 30, 2016
7
0
#9
First, you need to select Everything Search during the installation.

Then, run "everything /o" from the TCC prompt, select "Tools / Options", click on "Indexes / NTFS", and select the drives you want to include in the ES database.
O.k. I've read the FAQ on the voidtools website ... I have to add network drives in "Indexes / Folders". As they write this could be slow as it will use the same method as Windows search and not NTFS indexing ... I will check if this approach is still better than the old one with jpstree.idx.
 
Sep 30, 2016
7
0
#10
Up, Down, PgUp, PgDown is not working. Parallels said they can't help me because TCC is the only program where these keys do not work and therefore I shpuld contact TCC support ...
So please help me how I can remap these keys.
 
Sep 30, 2016
7
0
#12
I've read the "Key Mapping Directives" in help but this was of no help at all for me. This was all too cryptic. I've tried to put in the [4NT] section entries like
PrevHistory = Shift-F9 (before I tried Ctrl-U)
NextHistory = Shift-F10 (before I tried Ctrl-D)
but this does not work. BTW how can I enter something key combinations like "Ctrl+Alt" et.al.?