• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Keys in debug menu not working in bdebugger

Jun 2, 2008
21
0
#1
TCC 10,00,32 Windows XP [Version 5,1,2600]
TCC Build 32 Windows XP Build 2600 Service Pack

Using swedish keyboard and Regional and Language Options: Swedish

In TCMD v10 beta 31 and 32 the debug-menu commands below doesn't work when a btm-file is started in the debugger:
shift+f5 (stop debugging)
ctrl+break (pause)
f11 (step into)
ctrl+f11 (skip this line)
shift+f11 (run to breakpoint)
f9 (toggle breakpoint)
ctrl+shift+f11 (jump to this line)

Other behaviour:
ctrl+shift+f9 (clear all breakpoints) works when debug is not started
f10 (step over) activates the menues and sets focus on the File-menu.

Best regards
Berndt Berg
 

rconn

Administrator
Staff member
May 14, 2008
10,309
93
#2
Berndt Berg wrote:

> TCC 10,00,32 Windows XP [Version 5,1,2600]
> TCC Build 32 Windows XP Build 2600 Service Pack
>
> Using swedish keyboard and Regional and Language Options: Swedish
>
> In TCMD v10 beta 31 and 32 the debug-menu commands below doesn't work when a btm-file is started in the debugger:
> shift+f5 (stop debugging)
> ctrl+break (pause)
> f11 (step into)
> ctrl+f11 (skip this line)
> shift+f11 (run to breakpoint)
> f9 (toggle breakpoint)
> ctrl+shift+f11 (jump to this line)
We only test & support English, French, and German keyboards.

Did you try setting the shortcuts in the customize menu dialog?


> Other behaviour:
> ctrl+shift+f9 (clear all breakpoints) works when debug is not started
WAD. You can set breakpoints when you're not debugging, why not clear
them when you're not debugging?

Rex Conn
JP Software
 
Top Bottom