less pager locks up tcc

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
May 30, 2008
122
1
#1
The "less" pager (version 436, the latest version - binary build from http://www.greenwoodsoftware.com/less/) locks up Take Command for me (Version 11.00.48). I'm running on Windows 7 32 bit.

It's easy to demonstrate, with less in the path, and a text file "a" in the current directory, the command "less a" causes Take Command to lock up (specifically, the tab locks up, I can close that tab if I have multiple tabs).

As less uses a separate screen buffer for its display, I suspect that's related to the problem. Running less in a TCC window works fine. I get the same behaviour whether my Take Command tab is running TCC or CMD, so it looks like a Take Command issue rather than a TCC one.

I know I could use list, but (a) I like the features in less, and (b) my muscle memory is programmed to type "less", so I'd mistakenly use it even if I didn't want to...

Paul.
 
#2
Hello Paul,

I, too, am a big fan of less and talked to Mark (the author) about this
exact problem. It's a Windows 7 issue and apparently Mark has no access to
it and can't debug.

I'm running Windows7 64bit and have that issue.

Michael

On Fri, May 14, 2010 at 5:17 PM, p.f.moore <> wrote:


> The "less" pager (version 436, the latest version) locks up Take Command for me
> (Version 11.00.48). I'm running on Windows 7 32 bit.
>
> It's easy to demonstrate, with less in the path, and a text file "a" in the
> current directory, the command "less a" causes TCC to lock up (specifically,
> the tab locks up, I can close that tab if I have multiple tabs).
>
> As less uses a separate screen buffer for its display, I suspect that's
> related to the problem. Running less in a TCC window works fine. I get the
> same behaviour whether my Take Command tab is running TCC or CMD, so it
> looks like a Take Command issue rather than a TCC one.
>
> I know I could use list, but (a) I like the features in less, and (b) my
> muscle memory is programmed to type "less", so I'd mistakenly use it even if
> I didn't want to...
>
> Paul.
>
>
>
 
#3
| I know I could use list, but (a) I like the features in less, and
| (b) my muscle memory is programmed to type "less", so I'd mistakenly
| use it even if I didn't want to...

As to your second point, it would be trivial to:
alias less=*list
and your muscle memory would be properly utilized.
--
Steve
 

rconn

Administrator
Staff member
May 14, 2008
10,289
90
#4
> As less uses a separate screen buffer for its display, I suspect that's
> related to the problem. Running less in a TCC window works fine. I get
> the same behaviour whether my Take Command tab is running TCC or CMD,
> so it looks like a Take Command issue rather than a TCC one.
You cannot run apps in a Take Command window that switch screen buffers.
It's impossible for Take Command to detect that.

Rex Conn
JP Software
 
May 30, 2008
122
1
#7
That exact version of less works fine for me in Take Command (also the latest version). It even restores the screen properly after exiting...
Looks like it's a Win7 issue (from frossm's response below). Are you on another Windows version?

For what it's worth, I've found that the -X option to less disables the screen buffer switching (it's not obvious from the help that this is what it does). So

alias less=`less -X`

does the trick for me.

Paul
 

dim

Dimitry Andric
May 31, 2008
204
1
Netherlands
#8
On 2010-05-15 11:57, p.f.moore wrote:

> Looks like it's a Win7 issue (from frossm's response below). Are you on another Windows version?
Yes, I am on Windows XP x64. I tried it out in Windows 7, and it even manages to crash the Windows Console Host:

Problem signature:
Problem Event Name: APPCRASH
Application Name: conhost.exe
Application Version: 6.1.7600.16385
Application Timestamp: 4a5bc571
Fault Module Name: msvcrt.dll
Fault Module Version: 7.0.7600.16385
Fault Module Timestamp: 4a5bdfbe
Exception Code: c0000005
Exception Offset: 0000000000001188
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
Additional Information 1: d5fe
Additional Information 2: d5fe2002c604b5d9b2799f5eef1b75d7
Additional Information 3: 806e
Additional Information 4: 806e6104143c2e0f63067b1dd4406b29

Looks like a Windows bug to me. :)



> For what it's worth, I've found that the -X option to less disables the screen buffer switching (it's not obvious from the help that this is what it does). So
>
> alias less=`less -X`
>
> does the trick for me.
Yes, that also works here, but no screen restoring anymore, of course. Another way to do this is to set the LESS environment variable

set LESS=-X

or any other default options you may want to use (I usually use "-i -Q").
 
#9
Paul, I'll have to try -X. I didn't know what was causing the crash.
Thanks!

Frosty

On Sat, May 15, 2010 at 8:28 AM, dim <> wrote:


> On 2010-05-15 11:57, p.f.moore wrote:
>
> Quote:
> > Looks like it's a Win7 issue (from frossm's response below). Are you
> on another Windows version?
> Yes, I am on Windows XP x64. I tried it out in Windows 7, and it even
> manages to crash the Windows Console Host:
>
> Problem signature:
> Problem Event Name: APPCRASH
> Application Name: conhost.exe
> Application Version: 6.1.7600.16385
> Application Timestamp: 4a5bc571
> Fault Module Name: msvcrt.dll
> Fault Module Version: 7.0.7600.16385
> Fault Module Timestamp: 4a5bdfbe
> Exception Code: c0000005
> Exception Offset: 0000000000001188
> OS Version: 6.1.7600.2.0.0.256.1
> Locale ID: 1033
> Additional Information 1: d5fe
> Additional Information 2: d5fe2002c604b5d9b2799f5eef1b75d7
> Additional Information 3: 806e
> Additional Information 4: 806e6104143c2e0f63067b1dd4406b29
>
> Looks like a Windows bug to me.
>
>
>
> Quote:
> > For what it's worth, I've found that the -X option to less disables
> the screen buffer switching (it's not obvious from the help that this is
> what it does). So
> >
> > alias less=`less -X`
> >
> > does the trick for me.
> Yes, that also works here, but no screen restoring anymore, of course.
> Another way to do this is to set the LESS environment variable
>
> set LESS=-X
>
> or any other default options you may want to use (I usually use "-i -Q").
>
>
>