LIST edit not invoking my specified editor

Aug 28, 2008
107
3
I've set my preferred editor for the LIST command (on the "Windows" tab of the TCC options dialog) to Notepad++, the default path to which on my system is:

C:\Program Files\Notepad++\notepad++.exe​

When I use LIST to view the contents of a file, however, and press the hotkey to edit ('e'), the file is opened in Notepad. The setting seems completely ignored. Is this a bug?
 
Aug 28, 2008
107
3
Nevermind. I fixed my own problem. For the record, I was foolishly assuming TakeCommand would escape the path with quotes if needed. Once I made sure the path was escaped with quotes for Notepad++, that's what LIST launches. I hope that helps somebody else!
 
May 20, 2008
10,511
77
Syracuse, NY, USA
I have this (below) and I get Notepad. Quoting it doesn't help.
Code:
v:\> option editor
editor=L:\TextPad5\TextPad.exe