Long commands retrieved from command history have blank line when wrapped

Apr 18, 2014
264
9
TCC (x64) Version 26.02 Build 42 [26.02.42]
Microsoft Windows 10 Pro (2004) [10.0.19041.388]

I think this problem started with build 42 (possibly a side effect of the fix for no line wraps at the bottom of the screen buffer). It doesn't happen in version 25, but I haven't gone back to build 41 to confirm if it happens there. The problem occurs both in standalone TCC windows and TCC tabs within TCMD.

If there is a long command in the command history which, when recalled is longer than the width of the TCC window, a blank line appears in the command when it wraps. As an example, if I do a directory command for with a file that has a longish path and name...

Code:
d:\>dir /b c:\Windows\System32\DragDropExperienceCommon.dll
DragDropExperienceCommon.dll


Then I make the TCC window narrower such that the above command line has to wrap, and press the UP arrow to retrieve the command from history, a blank line appears:

Code:
d:\>dir /b c:\Windows\System32\DragDropExperienceComm

on.dll
 
Jan 12, 2014
407
7
Switzerland, SO
Here, it works correctly with same system and TCMD version as you, tried in TCC:

history_wrapping.png
 
May 20, 2008
10,910
84
Syracuse, NY, USA
Happens for some; doesn't happen for others. We need to figure out how to MAKE it happen or PREVENT it from happening. Any ideas?

1597936209458.png
 
Jun 26, 2015
10
0
Copied (CTRL-C) in Texteditor (Textpad). If I paste with SHIFT-INS the result is:
1598009209624.png

and when I get the command from history (CURSOR UP):
1598009282564.png

It's only a 'display problem', the command is executed correctly. (ps: unknown command is correct. the programm tf.exe does not exist on that location)
 

Attachments

  • 1598009138061.png
    1598009138061.png
    25.2 KB · Views: 38

TQ5

Dec 22, 2020
3
0
I have exactly the same problem. I have Take Command v26.02.43 x64.

1608688932220.png


Here's what happens when I type the command and then type the file:
1608688979232.png

This makes it difficult to correct typing since the cursor is above the text. According to my TakeCommand (check for updates), my software is up to date, and Windows 10 is up to date (version 10.0.19042.685).

This makes TakeCommand more difficult to use. What can be done? Thanks.
 
May 20, 2009
289
5
56
ITALY
In my case I paste a long command line from clipboard and it seems good and is executed correctly.
When I press arrow-up to recall that line there are empty lines and the cursor is in the middle of them.
I have "TCC 27.00.16 x64 Windows 10 [Version 10.0.19042.685]".

Regards

Rodolfo Giovanninetti



long_paste.png
 

TQ5

Dec 22, 2020
3
0
I am having the same problem (see screenshots above) and I'm not sure how to check whether I'm in legacy console mode or new console mode(see comment from December 22, TQ5). I have TC v26.02.43 x64, and it is the current update of V26. Thanks for your help.

This does not occur in my version of TC v22.00.40 x64 on a Surface Pro 7.
 
Last edited:
Apr 2, 2011
1,328
6
53
North Carolina, USA
@TQ5
From Legacy Console Mode – Windows Desktop - Windows Console
"
To use Legacy Console mode, first open any console hosting window. This is typically done by launching one of the command interpreters CMD or PowerShell.


Right-click on the application title bar and choose the Properties menu option. Choose the first tab, Options. Then check the box at the bottom of the page describing Use legacy console. Press the OK button to apply.


The setting can be reverted by returning to the same property sheet menu and unchecking the box then pressing OK."
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,304
78
Albuquerque, NM
prospero.unm.edu
@TQ5
From Legacy Console Mode – Windows Desktop - Windows Console
"
To use Legacy Console mode, first open any console hosting window. This is typically done by launching one of the command interpreters CMD or PowerShell.


Right-click on the application title bar and choose the Properties menu option. Choose the first tab, Options. Then check the box at the bottom of the page describing Use legacy console. Press the OK button to apply.

And after that, I think you need to close and restart the console program. Or close and restart Take Command. I think that setting is only checked when starting a console program -- though I could be mistaken.
 

TQ5

Dec 22, 2020
3
0
Thanks for the suggestion. Changing in and out of legacy mode didn't make a difference for TC v26.02.43 x64.
The problem described above (a blank line between two parts of a command line that is too long. does not occur in my version of TC v22.00.40 x64 on a Surface Pro 7.