Lost scheduled task association

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
I have scheduled *.btm tasks that are processed by JPsoft TCC.exe.
They have been working fine for years. Today, every time they run I get a prompt asking if I want to run them with TCC.

I refreshed the associations with JPSoft utilities, and with Windows associations. Inside the command prompt all works fine. ComSpec is correct. How can I get it to stop prompting me? These tasks are supposed to be automated. I am running Windows 10 home premium.
There is a new symptom. If you put a parameter in a shortcut that invokes a btm file, the btm file does not see it. Again, this is in btm files that have worked for years.

Do you need something on your ComSpec environment variable to ensure parms are passed through?
Maybe I am misunderstanding but I don't see that. I have ECHOARGS.BTM
echo %#: %$
do i=0 to %#
  echo %[%i]
and a shortcut with target
V:\echoargs.btm a b c
It works just fine.
3: a b c
Press any key when ready...
I would not expect you to have this problem. I did not have it either until this morning. All this has been working for years. I flipped over to Windows 10 a few months ago, and all worked fine.

It would be nice if there were a REG file with everything in it dealing with associations, parameters and comspec. Presumably TCCBatch is not complete.

I browsed through the registry looking for BTM and TCC. I could not believe how many times they appear. A sane design would need them no more than three times.

To add to the puzzle one of my schedules tasks out of the blue WORKED. I can't see any difference between it and the ones that do not work.

I get the feeling there is some malevolent human agent screwing with me.