1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New issue with ^C

Discussion in 'Support' started by Jim Cook, Apr 1, 2009.

  1. Jim Cook

    Joined:
    May 20, 2008
    Messages:
    605
    Likes Received:
    0
    I'm testing both the Ctrl-Break that terminated my TCMD session, and
    the missing Ctrl-C others have reported.

    TCC 10.00.64 Windows XP [Version 5.1.2600]
    TCC Build 64 Windows XP Build 2600 Service Pack 3
    Take Command v10.00.64

    Given this program:

    #include <stdio.h>
    #include <conio.h>

    int main(int argc, char * argv[])
    {
    int chr;

    while ( (chr = getch()) != 'Q' )
    {
    printf("%02X\n", chr);
    }

    return 0;
    }


    When running in a TCC stand alone window, and pressing Ctrl-A to
    Ctrl-D then Ctrl-Break, I get this output:
    D:\>test
    01
    02
    03
    04
    05
    ^C
    D:\>

    When running in TCMD, however, I get this. Note the missing 03 when
    Ctrl-C is pressed:
    D:\>test
    01
    02
    04
    05
    ^C
    D:\>

    I am pleased that I have not had a Ctrl-Break that terminated TCMD
    (yet), but need the Ctrl-C to return 03 when pressed.

    Using TCC 10.00.64 inside TCMD 10.00.60 works ok, whereas TCMD
    10.00.61 stops working. Version 61 said "Fixed a (Windows) bug with
    repeated ^Breaks sometimes terminating TCMD.EXE"

    I _really_ hope that the Ctrl-Break fix to avoid terminating the TCMD
    session does not require losing the Ctrl-C keystroke.

    --
    Jim Cook
    2009 Saturdays: 4/4, 6/6, 8/8, 10/10, 12/12 and 5/9, 9/5, 7/11, 11/7.
    Next year they're Sunday.
     
  2. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    Jim Cook wrote:
    ...
    | When running in a TCC stand alone window, and pressing Ctrl-A to
    | Ctrl-D then Ctrl-Break, I get this output:
    | D:\>test
    | 01
    | 02
    | 03
    | 04
    | 05
    | ^C
    | D:\>
    |
    | When running in TCMD, however, I get this. Note the missing 03 when
    | Ctrl-C is pressed:
    | D:\>test
    | 01
    | 02
    | 04
    | 05
    | ^C
    | D:\>
    |
    | I am pleased that I have not had a Ctrl-Break that terminated TCMD
    | (yet), but need the Ctrl-C to return 03 when pressed.

    I trust that in your test you made sure to use the left or right "Ctrl" key
    that in your TCMD options is set NOT to be intercepted by TCMD but passed on
    to the currently active console tab.
    --
    Steve
     
  3. Jim Cook

    Joined:
    May 20, 2008
    Messages:
    605
    Likes Received:
    0
    On Wed, Apr 1, 2009 at 8:54 AM, Steve Fábián <> wrote:

    Yes, which is why the Ctrl-A reports 01. I have the left Ctrl key
    reserved for TCMD, but the right Ctrl key should be (and is, by
    testing) passed on.

    I just double checked, and TCMD Options \ Configure Take Command \
    Tabs has both the Left Alt and Ctrl checked, and both the Right Alt
    and Ctrl unchecked.

    --
    Jim Cook
    2009 Saturdays: 4/4, 6/6, 8/8, 10/10, 12/12 and 5/9, 9/5, 7/11, 11/7.
    Next year they're Sunday.
     
  4. Emilio III

    Joined:
    Mar 9, 2009
    Messages:
    24
    Likes Received:
    0
    On Wed, Apr 01, 2009 at 10:35:11AM -0500, Jim Cook wrote:

    Assuming you meant Ctrl-A to Ctrl-E, I get the same results you did.
    The only surprise to me was that Ctrl-@ resulted in two numbers rather
    than one: 00 and 03 (both stand-alone and tabbed).
     
  5. Jim Cook

    Joined:
    May 20, 2008
    Messages:
    605
    Likes Received:
    0
    On Wed, Apr 1, 2009 at 12:36 PM, Emilio III <> wrote:


    I did mean Ctrl-E and not Ctrl-D. Thanks for the catch.
    Ctrl-@ can't return only 00 since an initial 00 is the lead-in for F1,
    Keypad Insert, and others.


    --
    Jim Cook
    2009 Saturdays: 4/4, 6/6, 8/8, 10/10, 12/12 and 5/9, 9/5, 7/11, 11/7.
    Next year they're Sunday.
     

Share This Page