1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New startup problem...

Discussion in 'Support' started by fishman@panix.com, Nov 10, 2009.

  1. fishman@panix.com

    Joined:
    Feb 21, 2009
    Messages:
    83
    Likes Received:
    0
    After Windows did its update today, I am getting a nastygram at TCC startup that says

    Error on line 91 of C:\Users\Harvey\AppData\Local\JPSoft\TCMD.INI:
    Invalid choice value for "FirewallType"
    Press any key when ready...

    Looking at that line and the following line I see

    FirewallType=P
    FirewallPort=1028

    Now I have not the foggiest idea what that means and the manual does not make it any easier. For a firewall, I use a combination of the Windows firewall and Trend Micro Internet Security. I see that there is a setting in the Option command for firewall things, but I have not the vaguest idea what to put there.

    HELP!!!!!!!!!!!

    Harvey
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,806
    Likes Received:
    82
    FirewallType is an integer value from 0 to 3. FirewallPort defaults to
    1080. I have no idea how you got a 'P' there, but I would suggest going to
    OPTION and selecting "none" for your firewall type.

    Rex Conn
    JP Software
     
  3. fishman@panix.com

    Joined:
    Feb 21, 2009
    Messages:
    83
    Likes Received:
    0

    Something very wrong here!!! I did as you said and set the firewall type to none with the option command and now those two lines TCMD.INI read

    FirewallType=ProxyPort
    FirewallPort=1024

    and I still get the same nastygram on startup. Should I set Firewall Type to 0 with the text editor?

    Harvey
     
  4. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,287
    Likes Received:
    39
    OPTION is putting that value there. Try this:

    * Rename or delete TCMD.INI. Close all instances.

    * Start TCC, then run OPTION. Select the "Internet" tab. Make some trivial change (e.g. space and then backspace in the SMTP server field.) Press OK, then exit TCC.

    * Start TCC again. See the error message?


    (If I then try to use OPTION to change the firewall type to None, OPTION writes a value of "ProxyPort" for FirewallType. A typo somewhere?)
     
  5. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,287
    Likes Received:
    39
    Or just delete the FirewallType= line; works for me.
     
  6. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,287
    Likes Received:
    39
    I can't reproduce this in build 33. (The value being written for the FirewallType= directive is the string "None", not the integer 0.... Doesn't cause an error message, though, so I guess it's kosher.)
     
  7. Jay Sage

    Joined:
    Jun 2, 2008
    Messages:
    284
    Likes Received:
    1
    This same problem has been driving me nuts on a new machine I've been
    setting up. I couldn't understand why these errors kept popping up. I
    hope build 33 solves that problem.

    -- Jay
     
  8. fishman@panix.com

    Joined:
    Feb 21, 2009
    Messages:
    83
    Likes Received:
    0
    O.K. When will Build 33 be released? All that I see there is Build 32, which definitely gives me the error and seemingly also other people.

    Strange as I have been running Build 32 for over a week and I never saw the error until Microsoft did the 9 fix update today. Apparently something in there did not agree with TCC Build 32.

    Harvey
     
  9. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    fishman@panix.com wrote:
    | O.K. When will Build 33 be released? All that I see there is Build
    | 32, which definitely gives me the error and seemingly also other
    | people.

    I downloaded B33 on 2009-11-10 at 20:14 EST (2009-11-11 @ 01:14 UTC) from
    the ftp site.
    --
    Steve
     
  10. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,806
    Likes Received:
    82
    It was released last night, about 3 1/2 hours before you posted your
    message. If you do a "Check for Updates" in TCMD it will show build 33.

    Rex Conn
    JP Software
     
  11. fishman@panix.com

    Joined:
    Feb 21, 2009
    Messages:
    83
    Likes Received:
    0
    Yes, I guess that I just did not update the download page in the browser. Sorry about that. I have it now and it does seem to fix the problem. Thanks!!

    Harvey
     

Share This Page